POJ1860,Currency Exchange,最近懒死了啊,,,
Currency ExchangeDescription
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies.
Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges,
and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative
sum of money while making his operations.
Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description
of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations
will be less than 104.
Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
Sample Output
YES
分析:
题意大概就是n总货币彼此兑换,可以把每个交换点看成一条路,每种货币看成点,A点到B点的汇率及手续费和B到A的汇率手续费可以看成边的双向...这样就可以构建成图了
再利用Bellman-Ford进行反向的松弛操作,最后检查是否存在正权回路...
code:
#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#define eps 1e-8
using namespace std;
int n,m,s;
int num;
double v;
double dis;
typedef struct edge
{
int a,b;
double r,c;
}edge;
edge eg;
bool Bellman()
{
memset(dis,0,sizeof(dis));
dis=v;
bool ok;
for(int i=1;i<=n-1;i++)
{
ok=false;
for(int j=0;j<num;j++)
if(dis.b]<(dis.a]-eg.c)*eg.r)
{
dis.b]=(dis.a]-eg.c)*eg.r;
ok=true;
}
if(dis>v+eps) return true;
if(!ok) break;
}
for(int k=0;k<num;k++)
if(dis.b]<(dis.a]-eg.c)*eg.r) return true;
return false;
}
int main()
{
//freopen("input.txt","r",stdin);
int a,b;
double Rab,Cab,Rba,Cba;
while(scanf("%d %d %d %lf",&n,&m,&s,&v)!=EOF)
{
memset(first,-1,sizeof(first));
num=0;
for(int i=0;i<m;i++)
{
scanf("%d %d %lf %lf %lf %lf",&a,&b,&Rab,&Cab,&Rba,&Cba);
eg.a=a;
eg.b=b;
eg.r=Rab;
eg.c=Cab;
eg.a=b;
eg.b=a;
eg.r=Rba;
eg.c=Cba;
}
if(Bellman()) printf("YES\n");
else printf("NO\n");
}
return 0;
}
页:
[1]