jjytr 发表于 2015-12-22 08:57:57

IPv6配置实验之BGP

1、实验拓扑

2、基础配置
R1配置

ipv6 unicast-routing
interface Loopback0
ipv6 address 1::1/64
ipv6 ospf 110 area 0         
interface Serial0/0
ipv6 address 2000:12::1/64
ipv6 ospf 110 area 0
ipv6 router ospf 110
router-id 1.1.1.1

R2配置
ipv6 unicast-routing
interface Loopback0
ipv6 address 2::2/64
ipv6 ospf 110 area 0      
interface Serial0/0
ipv6 address 2000:12::2/64
ipv6 ospf 110 area 0
interface Serial0/1
ipv6 address 2000:23::2/64
ipv6 router ospf 110
router-id 2.2.2.2

R3配置
ipv6 unicast-routing
interface Loopback0
ipv6 address 3::3/64
ipv6 ospf 110 area 0      
interface Serial0/0
ipv6 address 2000:34::3/64
ipv6 ospf 110 area 0
interface Serial0/1
ipv6 address 2000:23::3/64
ipv6 router ospf 110
router-id 3.3.3.3

R4配置
ipv6 unicast-routing
interface Loopback0
ipv6 address 4::4/64
ipv6 ospf 110 area 0      
interface Serial0/0
ipv6 address 2000:34::4/64
ipv6 ospf 110 area 0
interface Serial0/1
ipv6 address 2000:45::4/64
ipv6 ospf 110 area 0
ipv6 router ospf 110
router-id 4.4.4.4

R5配置
ipv6 unicast-routing
interface Loopback0
ipv6 address 5::5/64
ipv6 ospf 110 area 0
interface Serial0/1
no ip address
ipv6 address 2000:45::5/64
ipv6 router ospf 110
router-id 5.5.5.5

3、配置BGP
R1配置
router bgp 1
no synchronization
bgp router-id 1.1.1.1
neighbor 2::2 remote-as 1
neighbor 2::2 update-source Loopback0
no auto-summary
address-family ipv6
neighbor 2::2 activate
network 1::/64

R2配置
router bgp 1
no synchronization
bgp router-id 2.2.2.2
neighbor 1::1 remote-as 1
neighbor 1::1 update-source Loopback0
neighbor 2000:23::3 remote-as 3
no auto-summary
address-family ipv6
neighbor 1::1 activate
neighbor 1::1 next-hop-self
neighbor 2000:23::3 activate

R3配置
router bgp 3
no synchronization
bgp router-id 3.3.3.3
neighbor 4::4 remote-as 3
neighbor 4::4 update-source Loopback0
neighbor 5::5 remote-as 3
neighbor 5::5 update-source Loopback0
neighbor 2000:23::2 remote-as 1
no auto-summary
address-family ipv6
neighbor 4::4 activate
neighbor 4::4 next-hop-self
neighbor 5::5 activate
neighbor 5::5 next-hop-self
neighbor 2000:23::2 activate

R4配置
router bgp 3
no synchronization
bgp router-id 4.4.4.4
neighbor 3::3 remote-as 3
neighbor 3::3 update-source Loopback0
neighbor 5::5 remote-as 3
neighbor 5::5 update-source Loopback0
no auto-summary
address-family ipv6
neighbor 3::3 activate
neighbor 5::5 activate

R5配置
router bgp 3
no synchronization
bgp router-id 5.5.5.5
neighbor 3::3 remote-as 3
neighbor 3::3 update-source Loopback0
neighbor 4::4 remote-as 3
neighbor 4::4 update-source Loopback0
no auto-summary
address-family ipv6
neighbor 3::3 activate
neighbor 4::4 activate
network 5::/64

4、实验测试



页: [1]
查看完整版本: IPv6配置实验之BGP