IPv6 overlay tunnels 实验
基本配置:
R1:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Serial0/0
ip address 12.1.1.1 255.255.255.0
serial restart-delay 0
clock rate 64000
!
interface Serial0/1
ip address 13.1.1.1 255.255.255.0
serial restart-delay 0
clock rate 64000
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 110
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 12.1.1.0 0.0.0.255 area 0
network 13.1.1.0 0.0.0.255 area 0
!
no ip http server
no ip http secure-server
!
!
===================================================================
R2:
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Serial0/0
ip address 12.1.1.2 255.255.255.0
serial restart-delay 0
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet1/0
no ip address
half-duplex
ipv6 address 2::2/64
!
router ospf 110
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 12.1.1.0 0.0.0.255 area 0
!
no ip http server
no ip http secure-server
!
!
!
做tunnel:
R2#conf t
Enter configuration commands, one per line.End with CNTL/Z.
R2(config)#interface tunnel 2
R2(config-if)#
*Mar1 00:13:18.603: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel2, changed state to down
R2(config-if)#tunnel source 2.2.2.2 //源地址自己的环回口
R2(config-if)#tunnel destination 3.3.3.3//目的地址R3的环回口地址
R2(config-if)#tunnel mode ipv6ip //把IPv6转成IPv4
R2(config-if)#ipv6 enable //给IPV6地址
R2(config-if)# rip:只宣告tunnel接口和以太口
R2#conf t
Enter configuration commands, one per line.End with CNTL/Z.
R2(config)#ipv6 unicast-routing
R2(config)#ipv6 router rip A
R2(config-rtr)#exit
R2(config)#interface tunnel 2
R2(config-if)#ipv6 rip A enable
R2(config-if)#exit
R2(config)#interface ethernet 1/0
R2(config-if)#ipv6 rip A enable
R2(config-if)#
===================================================================
R3:
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Serial0/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/1
ip address 13.1.1.3 255.255.255.0
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet1/0
no ip address
half-duplex
ipv6 address 3::3/64
!
router ospf 110
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.0 0.0.0.255 area 0
network 13.1.1.0 0.0.0.255 area 0
!
no ip http server
no ip http secure-server
!
!
! 做tunnel:
R3#conf t
Enter configuration commands, one per line.End with CNTL/Z.
R3(config)#
*Mar1 00:19:47.099: %SYS-5-CONFIG_I: Configured from console by console
R3(config)#interface tunnel 3 //本地有效
R3(config-if)#tunnel source 3.3.3.3
R3(config-if)#tunnel destination 2.2.2.2
R3(config-if)#tunnel mode ipv6ip
R3(config-if)#rip:只宣告tunnel接口和以太口
R3#conf t
Enter configuration commands, one per line.End with CNTL/Z.
R3(config)#ipv6 unicast-routing
R3(config)#ipv6 router rip A
R3(config-rtr)#exit
R3(config)#interface tunnel 3
R3(config-if)#ipv6 rip A enable
R3(config-if)#exit
R3(config)#interface ethernet 1/0
R3(config-if)#ipv6 rip A enable
R3(config-if)#
拿分走人
页:
[1]