R1(config)#router ospf 1
R1(config-router)#network 1.1.1.1 0.0.0.0 area 0
R1(config-router)#network 10.1.1.1 0.0.0.3 area 0
R1(config-router)#network 40.4.4.1 0.0.0.3 area 0
R1(config-router)#exit
R2(config)#router ospf 1
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0
R2(config-router)#network 20.2.2.1 0.0.0.3 area 0
R2(config-router)#network 10.1.1.2 0.0.0.3 area 0
R2(config-router)#exit
R3(config)#router ospf 1
R3(config-router)#network 3.3.3.3 0.0.0.0 area 0
R3(config-router)#network 30.3.3.1 0.0.0.3 area 0
R3(config-router)#network 20.2.2.2 0.0.0.3 area 0
R3(config-router)#exit
R4(config)#router ospf 1
R4(config-router)#network 4.4.4.4 0.0.0.0 area 0
R4(config-router)#network 30.3.3.2 0.0.0.3 area 0
R4(config-router)#network 40.4.4.2 0.0.0.3 area 0
R4(config-router)#exit
R1(config)#do show ip route
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/2] via 10.1.1.2, 00:00:40, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/3] via 40.4.4.2, 00:00:40, FastEthernet1/0
[110/3] via 10.1.1.2, 00:00:40, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/2] via 40.4.4.2, 00:00:40, FastEthernet1/0
20.0.0.0/30 is subnetted, 1 subnets
O 20.2.2.0 [110/2] via 10.1.1.2, 00:00:42, FastEthernet0/0
40.0.0.0/30 is subnetted, 1 subnets
C 40.4.4.0 is directly connected, FastEthernet1/0
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
30.0.0.0/30 is subnetted, 1 subnets
O 30.3.3.0 [110/2] via 40.4.4.2, 00:00:44, FastEthernet1/0
R1#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/36/60 ms
R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/100/144 ms
R1#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/48/88 ms
R1#traceroute 3.3.3.3
Type escape sequence to abort.
Tracing the route to 3.3.3.3
1 40.4.4.2 36 msec
10.1.1.2 124 msec
40.4.4.2 32 msec
2 20.2.2.2 96 msec
30.3.3.1 64 msec
20.2.2.2 60 msec
R2(config)#interface fastEthernet 0/0
R2(config-if)#shutdown
R2(config-if)#exit
R1#traceroute 3.3.3.3
Type escape sequence to abort.
Tracing the route to 3.3.3.3
1 40.4.4.2 76 msec 60 msec 80 msec
2 30.3.3.1 92 msec 72 msec 60 msec