设为首页 收藏本站
查看: 1050|回复: 0

[经验分享] C.Talented Chef

[复制链接]

尚未签到

发表于 2015-11-26 05:08:55 | 显示全部楼层 |阅读模式
  

Time Limit: 2 Seconds
Memory Limit:
65536 KB
  
  As we all know, Coach Gao is a talented chef, because he is able to cook
M dishes in the same time. Tonight he is going to have a hearty dinner with his girlfriend at his home. Of course,
Coach Gao is going to cook all dishes himself, in order to show off his genius cooking skill to his girlfriend.

  To make full use of his genius in cooking, Coach Gao decides to prepare
N dishes for the dinner. The i-th dish contains Ai steps. The steps of a dish should be finished sequentially. In each minute of the cooking,
Coach Gao can choose at most M different dishes and finish one step for each dish chosen.

  Coach Gao wants to know the least time he needs to prepare the dinner.


Input
  There are multiple test cases. The first line of input contains an integer
T indicating the number of test cases. For each test case:
  The first line contains two integers N and M (1 <=
N, M <= 40000). The second line contains N integers
Ai (1 <= Ai <= 40000).

Output
  For each test case, output the least time (in minute) to finish all dishes.

Sample Input

2
3 2
2 2 2
10 6
1 2 3 4 5 6 7 8 9 10

Sample Output

3
10


  /********************************************************/
  题意:要制作n样菜,制作第i样菜需要Ai个步骤,每分钟至多可以选择m样菜完成一个步骤,问至少需要多少时间
  思路:刚开始,我的思路是选择步骤多的菜先完成的同时,按从大到小的顺序一一完成,可是转念一想是行不通的。所以,换个思路,假设全部都能恰好满足全部m个数字, if(sum%m == 0) k = sum / m ;

如果不能,我就多一次 if( sum%m!=0 ) k = sum / m &#43;1;

但是还要和max比较。因为,这个数字至少是要>=max 的。

取大的那一个。
  #include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
int t,n,m,i,sum,max,s,k;
scanf(&quot;%d&quot;,&t);
while(t--)
{
sum=max=0;
scanf(&quot;%d %d&quot;,&n,&m);
for(i=0;i<n;i++)
{
scanf(&quot;%d&quot;,&s);
sum+=s;
max=max>s?max:s;
}
if(sum%m)
k=sum/m+1;
else
k=sum/m;
printf(&quot;%d\n&quot;,k>max?k:max);
}
return 0;
}

运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-143566-1-1.html 上篇帖子: CodeChef STFM 下篇帖子: ZOJ Problem Set
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服E-mail:kefu@iyunv.com 客服QQ:1061981298


QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



合作伙伴: 青云cloud

快速回复 返回顶部 返回列表