设为首页 收藏本站
查看: 569|回复: 0

[经验分享] EIGRP配置实验之手动汇总

[复制链接]
累计签到:1 天
连续签到:1 天
发表于 2015-11-26 08:50:21 | 显示全部楼层 |阅读模式
1、实验拓扑
QQ截图20151126085015.png


2、主要事项
汇总路由在路由的出接收上做
汇总路由的开销取明细路由的最小开销值
配置自动汇总的路由器自动把汇总路由指向Null 0
只有最后一条明细路由downhou,汇总路由才消失

3、基础配置
R2

interface Loopback0
ip address 192.168.0.1 255.255.255.0
interface Loopback1
ip address 192.168.1.1 255.255.255.0   
interface Loopback2
ip address 192.168.2.1 255.255.255.0
interface Loopback3
ip address 192.168.3.1 255.255.255.0

interface Serial0/1
ip address 23.1.1.2 255.255.255.0
router eigrp 90
network 23.1.1.0 0.0.0.255
network 192.168.0.0 0.0.255.255
no auto-summary

R3
interface Serial0/0
ip address 34.1.1.3 255.255.255.0
interface Serial0/1
ip address 23.1.1.3 255.255.255.0
router eigrp 90
network 23.1.1.0 0.0.0.255
network 34.1.1.0 0.0.0.255
no auto-summary

R4
interface Serial0/0
ip address 34.1.1.4 255.255.255.0
router eigrp 90
network 34.1.1.0 0.0.0.255
no auto-summary

4、汇总前路由
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
D       34.1.1.0 [90/2681856] via 23.1.1.3, 00:43:00, Serial0/1
     23.0.0.0/24 is subnetted, 1 subnets
C       23.1.1.0 is directly connected, Serial0/1
C    192.168.0.0/24 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, Loopback1
C    192.168.2.0/24 is directly connected, Loopback2
C    192.168.3.0/24 is directly connected, Loopback3
R2#

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
C       34.1.1.0 is directly connected, Serial0/0
     23.0.0.0/24 is subnetted, 1 subnets
C       23.1.1.0 is directly connected, Serial0/1
D    192.168.0.0/24 [90/2297856] via 23.1.1.2, 00:01:51, Serial0/1
D    192.168.1.0/24 [90/2297856] via 23.1.1.2, 00:01:51, Serial0/1
D    192.168.2.0/24 [90/2297856] via 23.1.1.2, 00:01:51, Serial0/1
D    192.168.3.0/24 [90/2297856] via 23.1.1.2, 00:01:51, Serial0/1
R3#

R4#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
C       34.1.1.0 is directly connected, Serial0/0
     23.0.0.0/24 is subnetted, 1 subnets
D       23.1.1.0 [90/2681856] via 34.1.1.3, 00:42:41, Serial0/0
D    192.168.0.0/24 [90/2809856] via 34.1.1.3, 00:01:58, Serial0/0
D    192.168.1.0/24 [90/2809856] via 34.1.1.3, 00:01:58, Serial0/0
D    192.168.2.0/24 [90/2809856] via 34.1.1.3, 00:01:58, Serial0/0
D    192.168.3.0/24 [90/2809856] via 34.1.1.3, 00:01:58, Serial0/0
R4#

5、汇总后路由
R2(config)#int s0/1
R2(config-if)#ip summary-address eigrp 90 192.168.0.0 255.255.252.0

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
D       34.1.1.0 [90/2681856] via 23.1.1.3, 00:44:31, Serial0/1
     23.0.0.0/24 is subnetted, 1 subnets
C       23.1.1.0 is directly connected, Serial0/1
C    192.168.0.0/24 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, Loopback1
C    192.168.2.0/24 is directly connected, Loopback2
C    192.168.3.0/24 is directly connected, Loopback3
D    192.168.0.0/22 is a summary, 00:00:21, Null0
R2#

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
C       34.1.1.0 is directly connected, Serial0/0
     23.0.0.0/24 is subnetted, 1 subnets
C       23.1.1.0 is directly connected, Serial0/1
D    192.168.0.0/22 [90/2297856] via 23.1.1.2, 00:00:55, Serial0/1
R3#

R4#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
C       34.1.1.0 is directly connected, Serial0/0
     23.0.0.0/24 is subnetted, 1 subnets
D       23.1.1.0 [90/2681856] via 34.1.1.3, 00:44:29, Serial0/0
D    192.168.0.0/22 [90/2809856] via 34.1.1.3, 00:01:08, Serial0/0
R4#


运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-143658-1-1.html 上篇帖子: EIGRP配置实验之路由注入 下篇帖子: EIGRP DUAL网络收敛算法
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服E-mail:kefu@iyunv.com 客服QQ:1061981298


QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



合作伙伴: 青云cloud

快速回复 返回顶部 返回列表