设为首页 收藏本站
查看: 1211|回复: 0

[经验分享] 思科BGP AS-PATH配置实例

[复制链接]

尚未签到

发表于 2017-7-9 14:52:21 | 显示全部楼层 |阅读模式
  Cisco BGP AS-PATH配置实例如下图示:
DSC0000.png




R1:
interface Loopback0
ip address 1.1.1.1 255.255.255.255
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
interface FastEthernet0/1
ip address 14.1.1.1 255.255.255.0
router eigrp 1
network 1.1.1.1 0.0.0.0
network 12.1.1.0 0.0.0.255
network 14.1.1.0 0.0.0.255
no auto-summary
router bgp 100
bgp router-id 1.1.1.1
bgp log-neighbor-changes
no synchronization
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self
neighbor 4.4.4.4 remote-as 200
neighbor 4.4.4.4 ebgp-multihop 255
neighbor 4.4.4.4 update-source Loopback0
neighbor 4.4.4.4 next-hop-self
no auto-summary
R2:
interface Loopback0
ip address 2.2.2.2 255.255.255.255
interface FastEthernet0/0
ip address 12.1.1.2 255.255.255.0
interface FastEthernet0/1
ip address 23.1.1.2 255.255.255.0
router eigrp 1
network 2.2.2.2 0.0.0.0
network 12.1.1.0 0.0.0.255
network 23.1.1.0 0.0.0.255
no auto-summary
router bgp 100
no synchronization
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self
no auto-summary
R3:
interface Loopback0
ip address 3.3.3.3 255.255.255.255
interface FastEthernet0/0
ip address 34.1.1.3 255.255.255.0
interface FastEthernet0/1
ip address 23.1.1.3 255.255.255.0
router eigrp 1
network 3.3.3.3 0.0.0.0
network 23.1.1.0 0.0.0.255
network 34.1.1.0 0.0.0.255
no auto-summary
router bgp 100
no synchronization
bgp router-id 3.3.3.3
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
neighbor 4.4.4.4 remote-as 200
neighbor 4.4.4.4 ebgp-multihop 255
neighbor 4.4.4.4 update-source Loopback0
neighbor 4.4.4.4 next-hop-self
no auto-summary
R4:
interface Loopback0
ip address 4.4.4.4 255.255.255.255
interface FastEthernet0/0
ip address 34.1.1.4 255.255.255.0
interface FastEthernet0/1
ip address 14.1.1.4 255.255.255.0
router eigrp 1
network 4.4.4.4 0.0.0.0
network 14.1.1.0 0.0.0.255
network 34.1.1.0 0.0.0.255
no auto-summary
ip prefix-list 1 seq 5 permit 4.4.4.4/32
route-map as_path permit 10
match ip address prefix-list 1
set as-path prepend 600 700
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 ebgp-multihop 255
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 ebgp-multihop 255
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self
neighbor 3.3.3.3 route-map as_path out
no auto-summary


R4(config-router)#do ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/36/40 ms
R4(config-router)#do traceroute 1.1.1.1
Type escape sequence to abort.
Tracing the route to 1.1.1.1
1 34.1.1.3 8 msec 12 msec 24 msec
2 23.1.1.2 32 msec 36 msec 44 msec
3 12.1.1.1 32 msec 44 msec 32 msec
R4(config-router)#
R4(config-router)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
34.0.0.0/24 is subnetted, 1 subnets
C       34.1.1.0 is directly connected, FastEthernet0/0
1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/460800] via 34.1.1.3, 00:05:23, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/435200] via 34.1.1.3, 00:03:07, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/409600] via 34.1.1.3, 00:05:25, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected, Loopback0
23.0.0.0/24 is subnetted, 1 subnets
D       23.1.1.0 [90/307200] via 34.1.1.3, 00:05:36, FastEthernet0/0
12.0.0.0/24 is subnetted, 1 subnets
D       12.1.1.0 [90/332800] via 34.1.1.3, 00:03:10, FastEthernet0/0
14.0.0.0/24 is subnetted, 1 subnets
D       14.1.1.0 [90/358400] via 34.1.1.3, 00:05:37, FastEthernet0/0

运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-392016-1-1.html 上篇帖子: EIGRP-LAB 下篇帖子: 网络端口
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服E-mail:kefu@iyunv.com 客服QQ:1061981298


QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



合作伙伴: 青云cloud

快速回复 返回顶部 返回列表