设为首页 收藏本站
查看: 557|回复: 0

HDU 3183 A Magic Lamp (RMQ,4级)

[复制链接]

尚未签到

发表于 2015-8-20 13:44:13 | 显示全部楼层 |阅读模式
G - A Magic Lamp
Crawling in process...
Crawling failed
Time Limit:1000MS   
Memory Limit:32768KB     64bit IO Format:%I64d & %I64u


Submit
Status



Appoint description:
System Crawler (2013-05-30)



Description




Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams.


The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.

You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?





Input




There are several test cases.

Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.





Output




For each case, output the minimum result you can get in one line.

If the result contains leading zero, ignore it.





Sample Input






178543 4
1000001 1
100001 2
12345 2
54321 2




Sample Output






13
1
0
123
321


思路:转变一下,从原先的数中选出m个使其值最小,这样就是一个赤果果的RMQ了。


#include<cstring>
#include<iostream>
#include<cstdio>
#define FOR(i,a,b) for(int i=a;i<=b;++i)
#define clr(f,z) memset(f,z,sizeof(f))
#define ll(x) (1<<x)
#define check(i,j) s<=s[j]?i:j;
using namespace std;
const int mm=1009;
int rmq[mm][25];
int bit[mm];
char s[mm],ans[mm];
int n,m;
void initRMQ()
{ int len=strlen(s);
bit[0]=-1;
FOR(i,1,mm-1)bit=(i&(i-1))==0?bit[i-1]+1:bit[i-1];
FOR(i,0,len-1)rmq[0]=i;
FOR(i,1,bit[len])
for(int j=0;j+ll(i)-1<len;++j)
rmq[j]=check(rmq[j][i-1],rmq[j+ll(i-1)][i-1]);
}
int RMQ(int l,int r)
{
int t=bit[r-l+1];
r-=ll(t)-1;
int z=check(rmq[l][t],rmq[r][t]);
return z;
}
int main()
{
while(~scanf(&quot;%s%d&quot;,s,&n))
{
m=strlen(s);
n=m-n;///需要选n次最小值
int pos=0,to=0;
initRMQ();
for(int i=n;i>=1;--i)
{ //printf(&quot;%d x %d\n&quot;,to,m-i);
to=RMQ(to,m-i);
//cout<<to<<&quot; &quot;<<s[to]<<endl;
ans[pos++]=s[to++];
}
bool yes=0;
FOR(i,0,pos-1)
if(ans!='0'||yes)
{ yes=1;
putchar(ans);
}
if(!yes)putchar('0');
putchar('\n');
}
}

运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-101694-1-1.html 上篇帖子: linode空间lamp环境的搭建 下篇帖子: Ubuntu 安装LAMP ...
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服E-mail:kefu@iyunv.com 客服QQ:1061981298


QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



合作伙伴: 青云cloud

快速回复 返回顶部 返回列表