设为首页 收藏本站
查看: 718|回复: 0

[经验分享] POJ 3903 Stock Exchange 解题心得

[复制链接]
累计签到:1 天
连续签到:1 天
发表于 2015-9-11 13:44:06 | 显示全部楼层 |阅读模式
  原题:



Description




The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.


Input




Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer).
White spaces can occur freely in the input. The input data are correct and terminate with an end of file.


Output




The program prints the length of the longest rising trend.
For each set of data the program prints the result to the standard output from the beginning of a line.


Sample Input



6
5 2 1 4 5 3
3  
1 1 1
4
4 3 2 1


Sample Output



3
1
1


Hint




There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.





分析:

这题不能用n^2的算法过,要用LIS的nlogn算法过

下面介绍nlogn算法

这个有点贪心的意思了 ,

定义一个变量数组d[k]:长度为k的上升子序列的最末元素,若有多个长度为k的上升子序列,则记录最小的那个最末元素。

注意d中元素是单调递增的,下面要用到这个性质。
首先len = 1,d[1] = a[1],然后对a:若a>d[len],那么len++,d[len] = a;
否则,我们要从d[1]到d[len-1]中找到一个j,满足d[j-1]<a<d[j],则根据D的定义,我们需要更新长度为j的上升子序列的最末元素(使之为最小的)即 d[j] = a;
最终答案就是len
利用d的单调性,在查找j的时候可以二分查找,从而时间复杂度为nlogn。








还不懂可以去这里:http://blog.iyunv.com/shuangde800/article/details/7474903







代码:




#include<iostream>
#include<cstdio>
using namespace std;
const int N = 100000 + 10;
int a[N], dp[N];
//                                                                    while循环实现
int binsearch(int *d, int left, int right, int key)
{
int  mid;
while (left <= right)
{
mid = left + ((right - left) >>1);
if (d[mid] < key&&d[mid + 1] >= key)
return mid;
if (d[mid] < key&&d[mid + 1] < key)
left = mid + 1;
if (d[mid] == key)
right = mid - 1;
if (d[mid]>key)
right = mid - 1;
}
return  -1;
}
//                                                                                递归实现
//int binsearch(int *d,int left, int right, int key)
//{
//    //     搜索区间   [left ,right]
//   
//    if (left > right)
//        return -1;
//
//    int mid = left+(right-left)/2;
//    if (d[mid] < key&&d[mid + 1] >= key)
//        return mid;
//    if (d[mid] == key)
//        right = mid - 1;
//
//    else if (d[mid] < key){                    //可以优化?
//        left = mid+1;               
//    }
//    else if(d[mid]>key){
//        right = mid - 1;
//    }
//    return binsearch(d, left, right, key);
//}
int main()
{
//int aa[N] = { 1, 1, 1, 1, 1 };
//cout << binsearch(aa, 0, 5, 1);
int n;
while (cin >> n)
{
for (int i = 0; i < n; i++)
{
scanf("%d", a + i);
}
dp[1] = a[0];
int len = 1, protected_len;
for (int i = 1; i < n; i++)
{
if (i == 3)
int oiu=3;
if (a>dp[len]){
len++;
dp[len] = a;
}
else{
protected_len = binsearch(dp,1,len,a);
//cout << "protencetd=" << protected_len << ' ' << a << endl;
if (protected_len != -1){
protected_len++;
dp[protected_len] = a;
}
else{
dp[1] = a;
}
}
}
cout << len << endl;
}
return 0;
}
  

运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-112382-1-1.html 上篇帖子: POJ 3903 Stock Exchange(LIS) 下篇帖子: Exchange之准备AD及域
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服E-mail:kefu@iyunv.com 客服QQ:1061981298


QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



合作伙伴: 青云cloud

快速回复 返回顶部 返回列表