设为首页 收藏本站
查看: 1297|回复: 0

[经验分享] POJ 1860 Currency Exchange【bellman_ford判断是否有正环——基础入门】

[复制链接]

尚未签到

发表于 2015-9-11 13:58:36 | 显示全部楼层 |阅读模式
链接:


http://poj.org/problem?id=1860





http://acm.hust.edu.cn/vjudge/contest/view.action?cid=22010#problem/A











Currency Exchange


Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 16244 Accepted: 5656

Description



Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies.
Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges,
and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative
sum of money while making his operations.

Input



The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description
of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations
will be less than 104.

Output



If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES
Source



Northeastern Europe 2001, Northern Subregion





题意:






      一个城市有 N 种货币, 有 M 个兑换点

      兑换货币有一定的兑换率 r 和佣金 c

      如果货币 A 兑换 B 兑换率是 r ,佣金是 c

      那么value 个 A 可以换成 (value-c)*r 个 B

      每个兑换点能两种货币双向兑换,但是兑换比例和佣金不同

      输入时注意一下

      问:最后如果能够使得自己的钱变多,则输出 YES

            否则输出 NO


算法:bellman_ford 判断是否有正环




思路:







      直接按照输入顺序加双向边后,套用 bellman_ford模板

      看是否有正环,如果有正环,则说明可以通过这个正环

      使得自己的钱不断增多。





code:



1860Accepted140K32MSC&#43;&#43;2217B

/***********************************************************
AAccepted140 KB0 msC++1454 B
题意:一个城市有 N 种货币, 有 M 个兑换点
兑换货币有一定的兑换率 r 和佣金 c
如果货币 A 兑换 B 兑换率是 r ,佣金是 c
那么value 个 A 可以换成 (value-c)*r 个 B
每个兑换点能两种货币双向兑换,但是兑换比例和佣金不同
输入时注意一下
问:最后如果能够使得自己的钱变多,则输出 YES
否则输出 NO
算法:bellman_ford 判断是否有正环
思路:直接按照输入顺序加双向边后,套用 bellman_ford模板
看是否有正环,如果有正环,则说明可以通过这个正环
使得自己的钱不断增多。
***********************************************************/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn = 110;
double d[maxn];
int n, m, index; //index 表示开始拥有的货币的编号
double money;
struct Edge{
int u,v;
double r,c; //r:兑换率; c:佣金; 如果拿value个u换v ,则得到的 v :(value-c)*r
}edge[maxn*2];
bool bellman_ford()
{
for(int i = 0; i <= n; i++) d = 0; //初始没有其他货币
d[index] = money; //开始拥有的货币
for(int i = 1; i < n; i++) //n-1 轮松弛操作
{
bool flag = true; //标记是否松弛
for(int j = 0; j < m; j++)
{
int u = edge[j].u;
int v = edge[j].v;
double r = edge[j].r;
double c = edge[j].c;
if(d[v] < (d-c)*r) //松弛【也就是走这条路,钱变多】
{
d[v] = (d-c)*r;
flag = false;
}
}
if(flag) return false; //当前都无法松弛了,肯定没有正环了,直接返回
}
for(int i = 0; i < m; i++) //判断是否能继续松弛,如果能,就说明有正环
{
if(d[edge.v] < (d[edge.u] - edge.c)*edge.r)
return true;
}
return false;
}
int main()
{
while(scanf(&quot;%d%d%d%lf&quot;, &n,&m,&index,&money) != EOF)
{
int k = 0;
int u,v;
double r1,c1,r2,c2;
for(int i = 1; i <= m; i++) //双向兑换
{
scanf(&quot;%d%d%lf%lf%lf%lf&quot;, &u,&v,&r1,&c1,&r2,&c2);
edge[k].u = u;
edge[k].v = v;
edge[k].r = r1;
edge[k++].c = c1;
edge[k].u = v;
edge[k].v = u;
edge[k].r = r2;
edge[k++].c = c2;
}
m = 2*m;
if(bellman_ford()) printf(&quot;YES\n&quot;); //如果有正环
else printf(&quot;NO\n&quot;);
}
}

运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-112392-1-1.html 上篇帖子: Outlook-----use cached exchange mode在注册表中的值 下篇帖子: Exchange 2010 activesync doesn’t work domain admin group members【转】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服E-mail:kefu@iyunv.com 客服QQ:1061981298


QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



合作伙伴: 青云cloud

快速回复 返回顶部 返回列表