设为首页 收藏本站
查看: 953|回复: 0

[经验分享] The Exchange of Items (141

[复制链接]

尚未签到

发表于 2015-11-24 15:04:23 | 显示全部楼层 |阅读模式
  

The Exchange of Items

Time Limit: 2 Seconds      
Memory Limit:
65536 KB
  
  Bob lives in an ancient village, where transactions are done by one item exchange with another. Bob is very clever and he knows what items will become more valuable later on. So, Bob has decided to do some business with villagers.

  At first, Bob has N kinds of items indexed from 1 to N, and each item has
Ai. There are M ways to exchanges items. For the
ith way (Xi, Yi), Bob can exchange one
Xith item to one Yith item, vice versa. Now Bob wants that his
ith item has exactly Bi, and he wonders what the minimal times of transactions is.


Input
  There are multiple test cases.

For each test case: the first line contains two integers: N and M (1 <=
N, M <= 100).

The next N lines contains two integers: Ai and
Bi (1 <= Ai, Bi <= 10,000).

Following M lines contains two integers: Xi and
Yi (1 <= Xi, Yi <=
N).

There is one empty line between test cases.

Output
  For each test case output the minimal times of transactions. If Bob could not reach his goal, output -1 instead.


Sample Input

2 1
1 2
2 1
1 2
4 2
1 3
2 1
3 2
2 3
1 2
3 4

Sample Output

1
-1


  


  题意:现在有N个物品,进行物物交换,告诉每个物品 i 的初始时的个数A和最终想得到的个数B,M种交换方式,问为了达到目的最少的交换次数是多少。
  思路:最近在做最小割,看到什么都想往最小割上套 DSC0000.gif 发现不行,恩,好像费用流可以搞。添加源点s和汇点t,如果A>B,也就是物品i的初始个数大于最终个数,那么我们从源点向i连边,容量为A-B,费用为0,同样如果B>A,i向汇点连边,容量为B-A,费用为0,另外M种交换方式建双向边,容量为INF(因为理论上可以进行无数次交换嘛),费用为1,跑一遍费用流。
  代码:
  #include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,&quot;/STACK:102400000,102400000&quot;)
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
#define FRE(i,a,b)  for(i = a; i <= b; i++)
#define FREE(i,a,b) for(i = a; i >= b; i--)
#define FRL(i,a,b)  for(i = a; i < b; i++)
#define FRLL(i,a,b) for(i = a; i > b; i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf(&quot;%d&quot;, &n)
#define sff(a,b)    scanf(&quot;%d %d&quot;, &a, &b)
#define sfff(a,b,c) scanf(&quot;%d %d %d&quot;, &a, &b, &c)
#define pf          printf
#define DBG         pf(&quot;Hi\n&quot;)
typedef long long ll;
using namespace std;
#define INF 0x3f3f3f3f
#define mod 1000000009
const int maxn = 10005;
const int MAXN = 2005;
const int MAXM = 200010;
int n,m;
int A[MAXN],B[MAXN],X[MAXN],Y[MAXN];
struct Edge
{
int to,next,cap,flow,cost;
}edge[MAXM];
int head[MAXN],tol;
int pre[MAXN],dis[MAXN];
bool vis[MAXN];
int N;
void init(int n)
{
N=n;
tol=0;
memset(head,-1,sizeof(head));
}
void addedge(int u,int v,int cap,int cost)
{
edge[tol].to=v;
edge[tol].cap=cap;
edge[tol].cost=cost;
edge[tol].flow=0;
edge[tol].next=head;
head=tol++;
edge[tol].to=u;
edge[tol].cap=0;
edge[tol].cost=-cost;
edge[tol].flow=0;
edge[tol].next=head[v];
head[v]=tol++;
}
bool spfa(int s,int t)
{
queue<int>q;
for (int i=0;i<N;i++)
{
dis=INF;
vis=false;
pre=-1;
}
dis=0;
vis=true;
q.push(s);
while (!q.empty())
{
int u=q.front();
q.pop();
vis=false;
for (int i=head;i!=-1;i=edge.next)
{
int v=edge.to;
if (edge.cap > edge.flow && dis[v] > dis + edge.cost)
{
dis[v]=dis + edge.cost;
pre[v]=i;
if (!vis[v])
{
vis[v]=true;
q.push(v);
}
}
}
}
if (pre[t]==-1) return false;
else return true;
}
//返回的是最大流,cost存的是最小费用
int minCostMaxflow(int s,int t,int &cost)
{
int flow=0;
cost=0;
while (spfa(s,t))
{
int Min=INF;
for (int i=pre[t];i!=-1;i=pre[edge[i^1].to])
{
if (Min > edge.cap-edge.flow)
Min=edge.cap-edge.flow;
}
for (int i=pre[t];i!=-1;i=pre[edge[i^1].to])
{
edge.flow+=Min;
edge[i^1].flow-=Min;
cost+=edge.cost*Min;
}
flow+=Min;
}
return flow;
}
int main()
{
#ifndef ONLINE_JUDGE
freopen(&quot;C:/Users/lyf/Desktop/IN.txt&quot;,&quot;r&quot;,stdin);
#endif
int i,j,u,v;
while (~sff(n,m))
{
int all=0;
init(n+2);
int s=0,t=n+1;
for (i=1;i<=n;i++)
{
sff(A,B);
if (A>B)
addedge(s,i,A-B,0);
else if (A<B)
{
addedge(i,t,B-A,0);
all+=(B-A);
}
}
for (i=0;i<m;i++)
{
sff(u,v);
addedge(u,v,INF,1);
addedge(v,u,INF,1);
}
int cost,ans;
ans=minCostMaxflow(s,t,cost);
if (ans<all)
pf(&quot;-1\n&quot;);
else
pf(&quot;%d\n&quot;,cost);
}
return 0;
}

运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-143175-1-1.html 上篇帖子: poj 3903 Stock Exchange (最长上升子序列) 下篇帖子: Exchange server 2013的改进概览
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服E-mail:kefu@iyunv.com 客服QQ:1061981298


QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



合作伙伴: 青云cloud

快速回复 返回顶部 返回列表