设为首页 收藏本站
查看: 1221|回复: 0

[经验分享] 四川省ACM省赛B题,优先队列+BFS Charitable Exchange

[复制链接]

尚未签到

发表于 2015-11-24 15:28:07 | 显示全部楼层 |阅读模式
  题目链接:http://acm.uestc.edu.cn/problem.php?pid=1558&cid=129
  Description                                Have you ever heard a star charity show called Charitable Exchange? In this show, a famous star starts with a small item which values 1 yuan. Then, through the efforts of repeatedly exchanges which continuously increase the value of item in hand, he (she) finally brings back a valuable item and donates it to the needy.
In each exchange, one can exchange for an item of Vi yuan if he (she) has an item values more than or equal to Ri yuan, with a time cost of Ti minutes.
Now, you task is help the star to exchange for an item which values more than or equal to M yuan with the minimum time.
                              Input  
The first line of the input is T (no more than 20), which stands for the number of test cases you need to solve.
For each case, two integers N, M (1 <= N <= 10^5, 1 <= M <= 10^9) in the first line indicates the number of available exchanges and the expected value of final item. Then N lines follow, each line describes an exchange with 3 integers Vi, Ri, Ti (1 <= Ri <= Vi <= 10^9, 1 <= Ti <= 10^9).

                              
                              Output                                
For every test case, you should output &quot;Case #k: &quot; first, where k indicates the case number and counts from 1. Then output the minimum time. Output “-1” if no solution can be found.
                              Sample Input                                3
3 10
5 1 3
8 2 5
10 9 2
4 5
2 1 1
3 2 1
4 3 1
8 4 1
5 9
5 1 1
10 4 10
8 1 10
11 6 1
7 3 8
                              Sample Output                                Case #1: -1
Case #2: 4
Case #3: 10
          SourceSichuan State Programming Contest 2011

  解题思路:
  由于题目数据量很大,点的个数达到了10^5,所以普通的图论最短路方法是要超时的。
  所以我想到了BFS,但是这个题目,如果仅仅使用BFS的话还是会超时的。
  于是我们可以更进一步优化,变为优先队列+BFS
  

  我们可以先对所有的边按起点(初始金额)排序。
  然后优先队列我们用每一条边的交换时间来作为优先条件。
  

  我的代码:
  
#include<stdio.h>
#include<queue>
#include<algorithm>
using namespace std;
struct edge
{
long long v;
long long u;
long long t;
};
struct node
{
long long money;
long long t;
friend bool operator<(node a,node b)
{
return a.t>b.t;
}
};
edge e[100005];
long long num,m;
bool cmp(edge a,edge b)
{
return a.u<b.u;
}
long long bfs()
{
node k1,k2;
long long i,left=1;
priority_queue<node>q;
k1.money=1;
k1.t=0;
q.push(k1);
while(!q.empty())
{
k2=q.top();
q.pop();
if(k2.money>=m)
return k2.t;
for(i=left;i<=num;i++)
{
if(k2.money>=e.u&&e.v>k2.money)
{
k1.money=e.v;
k1.t=k2.t+e.t;
q.push(k1);
}
if(k2.money<e.u)
break;
}
left=i;
}
return -1;
}
int main()
{
long long n,i,t,T,ans;
long long a,b,c;
scanf(&quot;%lld&quot;,&T);
for(t=1;t<=T;t++)
{
num=0;
scanf(&quot;%lld%lld&quot;,&n,&m);
for(i=1;i<=n;i++)
{
scanf(&quot;%lld%lld%lld&quot;,&a,&b,&c);
if(a==b)
continue;
num++;
e[num].u=b;
e[num].v=a;
e[num].t=c;
}
sort(e+1,e+1+num,cmp);
ans=bfs();
printf(&quot;Case #%lld: %lld\n&quot;,t,ans);
}
return 0;
}
  

运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-143192-1-1.html 上篇帖子: Exchange Storage Architecture 下篇帖子: Project Server与Exchange任务协同(上)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服E-mail:kefu@iyunv.com 客服QQ:1061981298


QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



合作伙伴: 青云cloud

快速回复 返回顶部 返回列表