设为首页 收藏本站
查看: 523|回复: 0

[经验分享] ZOJ 3885--The Exchange of Items【最小费用最大流 && 建图】

[复制链接]

尚未签到

发表于 2015-11-25 01:54:22 | 显示全部楼层 |阅读模式
  

The Exchange of Items

Time Limit: 2 Seconds      
Memory Limit:
65536 KB
  
  Bob lives in an ancient village, where transactions are done by one item exchange with another. Bob is very clever and he knows what items will become more valuable later on. So, Bob has decided to do some business with villagers.
  At first, Bob has N kinds of items indexed from 1 to N, and each item hasAi. There are
M ways to exchanges items. For theith way (Xi,
Yi), Bob can exchange oneXith item to one
Yith item, vice versa. Now Bob wants that hisith item has exactly
Bi, and he wonders what the minimal times of transactions is.

Input
  There are multiple test cases.

For each test case: the first line contains two integers: N and M (1 <=N,
M <= 100).

The next N lines contains two integers: Ai and
Bi (1 <= Ai, Bi <= 10,000).

Following M lines contains two integers: Xi and
Yi (1 <= Xi, Yi <=
N).

There is one empty line between test cases.

Output
  For each test case output the minimal times of transactions. If Bob could not reach his goal, output -1 instead.

Sample Input

2 1
1 2
2 1
1 2
4 2
1 3
2 1
3 2
2 3
1 2
3 4

Sample Output

1
-1


  


  题意:
  Bob有N种物品,每种物品有Ai个,他想换成Bi个,现在有M种交换方式(一个第i种物品可以换成一个第j种物品,反之亦然,双向的),现在问,Bob达成目标所需的最小交换次数,当不可能完成交换时,输出-1。


  


  解析:比较好想的思路。设置一个超级源点,连向所有的物品,容量为Ai,费用为0,设置一个超级汇点,使所有物品连向超级汇点,容量为Bi费用为0,每种交换方式,连接交换双方(双向)容量为INF,费用为1。建完图跑最小费,看最后的最大流会不会等于Bi的和(满流),会的话输出最小费用。
  

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#define maxn 110
#define maxm 110000
#define INF 0x3f3f3f3f
using namespace std;
int n, m;
int inset, outset;
int sum;
struct node {
int u, v, cap, flow, cost, next;
};
node edge[maxm];
int head[maxn], cnt;
int dist[maxn], vis[maxn];
int per[maxn];
void init(){
cnt = 0;
memset(head, -1, sizeof(head));
}
void add(int u, int v, int w, int c){
node E1 = {u, v, w, 0, c, head};
edge[cnt] = E1;
head = cnt++;
node E2 = {v, u, 0, 0, -c, head[v]};
edge[cnt] = E2;
head[v] = cnt++;
}
void getmap(){
int a, b;
sum = 0;
outset = 0;
inset = n + 1;
for(int i = 1; i <= n; ++i){
scanf(&quot;%d%d&quot;, &a, &b);
sum += b;
add(outset, i, a, 0);
add(i, inset, b, 0);
}
for(int i = 1; i <= m; ++i){
scanf(&quot;%d%d&quot;, &a, &b);
add(a, b, INF, 1);
add(b, a, INF, 1);
}
}
bool SPFA(int st, int ed){
queue<int>q;
for(int i = 0; i <= inset; ++i){
dist = INF;
vis = 0;
per = -1;
}
dist[st] = 0;
vis[st] = 1;
q.push(st);
while(!q.empty()){
int u = q.front();
q.pop();
vis = 0;
for(int i = head; i != -1; i = edge.next){
node E = edge;
if(dist[E.v] > dist + E.cost && E.cap > E.flow){
dist[E.v] = dist + E.cost;
per[E.v] = i;
if(!vis[E.v]){
vis[E.v] = 1;
q.push(E.v);
}
}
}
}
return per[ed] != -1;
}
void MCMF(int st, int ed, int &cost, int &flow){
flow = 0;
cost = 0;
while(SPFA(st, ed)){
int mins = INF;
for(int i = per[ed]; i != -1; i = per[edge[i ^ 1].v]){
mins = min(mins, edge.cap - edge.flow);
}
for(int i = per[ed]; i != -1; i = per[edge[i ^ 1].v]){
edge.flow += mins;
edge[i ^ 1].flow -= mins;
cost += edge.cost * mins;
}
flow += mins;
}
}
int main (){
while(scanf(&quot;%d%d&quot;, &n, &m) != EOF){
init();
getmap();
int cost ,flow;
MCMF(outset, inset, cost, flow);
if(flow == sum)
printf(&quot;%d\n&quot;, cost);
else
printf(&quot;-1\n&quot;);
}
return 0;
}



  

运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-143211-1-1.html 上篇帖子: Exchange 2010 content index state crawling 下篇帖子: Exchange 中配置 SMTP 连接器以链接到 Internet 域
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服E-mail:kefu@iyunv.com 客服QQ:1061981298


QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



合作伙伴: 青云cloud

快速回复 返回顶部 返回列表