设为首页 收藏本站
查看: 857|回复: 0

[经验分享] codechef Cutting Recipes题解

[复制链接]

尚未签到

发表于 2015-11-26 08:31:36 | 显示全部楼层 |阅读模式
  


Cutting Recipes

  

The chef has a recipe he wishes to use for his guests,

but the recipe will make far more food than he can serve to the guests.

The chef therefore would like to make a reduced version of the recipe which has the same ratios of ingredients, but makes less food.

The chef, however, does not like fractions.

The original recipe contains only whole numbers of ingredients,

and the chef wants the reduced recipe to only contain whole numbers of ingredients as well.

Help the chef determine how much of each ingredient to use in order to make as little food as possible.



Input



Input will begin with an integer T, the number of test cases.

Each test case consists of a single line.

The line begins with a positive integer N, the number of ingredients.

N integers follow, each indicating the quantity of a particular ingredient that is used.



Output



For each test case, output exactly N space-separated integers on a line,

giving the quantity of each ingredient that the chef should use in order to make as little food as possible.



Sample Input


3
2 4 4
3 2 3 4
4 3 15 9 6


Sample Output


1 1
2 3 4
1 5 3 2

  问题就是:求一个数组的所有数的最大公约数
  #pragma once
#include <stdio.h>
namespace cutName
{
int gcd(int a, int b)
{
if (0 == b) return a;
return gcd(b, a % b);
}
}
int CuttingRecipes()
{
int T;
scanf(&quot;%d&quot;, &T);
while (T--)
{
int n = 0;
scanf(&quot;%d&quot;, &n);
if (0 == n) continue;
int *A = new int[n];
for (int i = 0; i < n; i++)
{
scanf(&quot;%d&quot;, &A);
}
int g = A[0];
for (int i = 1; i < n; i++)
{
g = cutName::gcd(A, g);
}
for (int i = 0; i < n; i++)
{
printf(&quot;%d &quot;, A / g);
}
putc('\n', stdout);
delete [] A;
}
return 0;
}




  


  

运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-143619-1-1.html 上篇帖子: configure chef master 下篇帖子: codechef The Morning Commute 题解
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服E-mail:kefu@iyunv.com 客服QQ:1061981298


QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



合作伙伴: 青云cloud

快速回复 返回顶部 返回列表