1、as-path选路解析 属性
| 传播范围
| 默认值
| 优先值 | 方向
| 备注 | weight | 本路由器 | 本路由器32768,其他路由器0 | 大值优先 | IN | CISCO私有
| Local preference | AS内部 | 100:边界路由器,通告给IBGP邻居,告知如何离开本AS | 大值优先 | OUT |
| As path | AS之间 | 无 | 短优先 | IN、OUT |
| 修改As path值的方法:
方法一:在OUT方向上修改As path值,例如
ip prefix-list 1 seq 5 permit 33.33.33.0/24 route-map AS permit 10 match ip address prefix-list 1 set as-path prepend 2 2 2 2 2 route-map AS permit 20 router bgp 3 neighbor 23.1.1.2 route-map AS out 方法二:在IN方向上修改As path值,例如
2、实验拓扑
3、基础配置 R1配置
interface Loopback0 ip address 1.1.1.1 255.255.255.0 interface Serial0/0 ip address 13.1.1.1 255.255.255.0 interface Serial0/1 ip address 14.1.1.1 255.255.255.0 router ospf 110 router-id 1.1.1.1 log-adjacency-changes network 1.1.1.0 0.0.0.255 area 0 network 14.1.1.0 0.0.0.255 area 0 router bgp 4 no synchronization bgp router-id 1.1.1.1 neighbor 4.4.4.4 remote-as 4 neighbor 4.4.4.4 update-source Loopback0 neighbor 4.4.4.4 next-hop-self neighbor 13.1.1.3 remote-as 3 no auto-summary
R2配置 interface Loopback0 ip address 2.2.2.2 255.255.255.0 interface Serial0/1 ip address 23.1.1.2 255.255.255.0 interface FastEthernet1/0 ip address 24.1.1.2 255.255.255.0 router ospf 110 router-id 2.2.2.2 network 2.2.2.0 0.0.0.255 area 0 network 24.1.1.0 0.0.0.255 area 0 router bgp 4 no synchronization bgp router-id 2.2.2.2 neighbor 4.4.4.4 remote-as 4 neighbor 4.4.4.4 update-source Loopback0 neighbor 4.4.4.4 next-hop-self neighbor 23.1.1.3 remote-as 3 no auto-summary
R3配置 interface Loopback0 ip address 3.3.3.3 255.255.255.0 interface Loopback1 ip address 33.33.33.33 255.255.255.0 interface Serial0/0 ip address 13.1.1.3 255.255.255.0 interface Serial0/1 ip address 23.1.1.3 255.255.255.0router bgp 3 no synchronization bgp router-id 3.3.3.3 network 3.3.3.0 mask 255.255.255.0 network 33.33.33.0 mask 255.255.255.0 neighbor 13.1.1.1 remote-as 4 neighbor 23.1.1.2 remote-as 4 no auto-summary
R4配置 interface Loopback0 ip address 4.4.4.4 255.255.255.0 interface Serial0/1 ip address 14.1.1.4 255.255.255.0 interface FastEthernet1/0 ip address 24.1.1.4 255.255.255.0 router ospf 110 router-id 4.4.4.4 network 4.4.4.0 0.0.0.255 area 0 network 14.1.1.0 0.0.0.255 area 0 network 24.1.1.0 0.0.0.255 area 0 router bgp 4 no synchronization bgp router-id 4.4.4.4 neighbor 1.1.1.1 remote-as 4 neighbor 1.1.1.1 update-source Loopback0 neighbor 2.2.2.2 remote-as 4 neighbor 2.2.2.2 update-source Loopback0 no auto-summary
4、默认选路
根据BGP选路原则第八条可以知道,R4到达3.3.3.0/24、33.33.33.0/24都是经过R2。
5、在OUT方向上修改As path值
R4到达3.3.3.0/24、33.33.33.0/24都是经过R2,我们通过修改As path值将R4到达3.3.3.0/24经过R2、达到33.33.33.0/24都是经过R1。
R3配置
ip prefix-list 1 seq 5 permit 33.33.33.0/24
route-map AS permit 10
match ip address prefix-list 1
set as-path prepend 2 2 2 2 2
route-map AS permit 20
router bgp 3
neighbor 23.1.1.2 route-map AS out
6、在IN方向上修改As path值
R4到达3.3.3.0/24、33.33.33.0/24都是经过R2,我们通过修改As path值将R4到达3.3.3.0/24经过R2、达到33.33.33.0/24都是经过R1。
R2配置
ip prefix-list 1 seq 5 permit 33.33.33.0/24
route-map AS permit 10
match ip address prefix-list 1
set as-path prepend 2 2 2 2 2
route-map AS permit 20
router bgp 4
neighbor 23.1.1.3 route-map AS in
|