设为首页 收藏本站
查看: 2047|回复: 0

[经验分享] 多路径路由控制(双向重分布产生次优路由其解决办法)

[复制链接]
累计签到:1 天
连续签到:1 天
发表于 2016-3-18 08:57:00 | 显示全部楼层 |阅读模式
多路径路由控制(因双向重分布产生次优路由其解决办法)
1、网络拓扑图
QQ截图20160318085521.png
IOU设备接口连接说明:
r1 e0/0 r2 e0/0
r2 s1/0 r3 s1/0
r2 s1/1 r5 s1/1
r3 s1/1 r4 s1/1
r5 s1/0 r4 s1/0

1:0/0 2:0/0 rip
2:1/0 3:1/0 rip
2:1/1 5:1/1 rip
3:1/1 4:1/1 ospf
5:1/0 4:1/0 ospf

2、设备基本配置信息
r1#
interface Loopback0
ipaddress 1.1.1.1 255.255.255.255
!
interface Loopback1
ipaddress 11.11.11.11 255.255.255.255
!
interface Ethernet0/0
ipaddress 192.168.12.1 255.255.255.0
router rip
version 2
passive-interface default
nopassive-interface Ethernet0/0
network 1.0.0.0
network 11.0.0.0
network 192.168.12.0
noauto-summary

r2#
interface Ethernet0/0
ipaddress 192.168.12.2 255.255.255.0
interface Serial1/0
ipaddress 192.168.23.2 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
ipaddress 192.168.25.2 255.255.255.0
serial restart-delay 0
router rip
version 2
passive-interface default
nopassive-interface Ethernet0/0
nopassive-interface Serial1/0
nopassive-interface Serial1/1
network 192.168.12.0
network 192.168.23.0
network 192.168.25.0
noauto-summary

r3#
interface Loopback0
ipaddress 3.3.3.3 255.255.255.255
interface Serial1/0
ipaddress 192.168.23.3 255.255.255.0
nofair-queue
serial restart-delay 0
!
interface Serial1/1
ipaddress 192.168.34.3 255.255.255.0
serial restart-delay 0
!
router ospf 100
router-id 3.3.3.3
log-adjacency-changes
redistribute rip metric 1000 metric-type 1subnets tag 3
passive-interface default
nopassive-interface Serial1/1
network 3.3.3.30.0.0.0 area 0
network 192.168.34.0 0.0.0.255area 0
distribute-list route-map 5 in
!
router rip
version 2
redistribute ospf 100 metric 10
passive-interface default
nopassive-interface Serial1/0
network 192.168.23.0
noauto-summary
route-map 5 deny 10
match tag 5
!
route-map 5 permit 20
r4#
interface Loopback0
ip address4.4.4.4 255.255.255.255
interface Serial1/0
ipaddress 192.168.45.4 255.255.255.0
nofair-queue
serial restart-delay 0
!
interface Serial1/1
ipaddress 192.168.34.4 255.255.255.0
serial restart-delay 0
router ospf 100
router-id 4.4.4.4
log-adjacency-changes
passive-interface default
nopassive-interface Serial1/0
nopassive-interface Serial1/1
network 4.4.4.40.0.0.0 area 0
network 192.168.34.0 0.0.0.255area 0
network 192.168.45.0 0.0.0.255area 0

r5#
interface Loopback0
ipaddress 5.5.5.5 255.255.255.255
interface Serial1/0
ipaddress 192.168.45.5 255.255.255.0
nofair-queue
serial restart-delay 0
!
interface Serial1/1
ipaddress 192.168.25.5 255.255.255.0
serial restart-delay 0
router ospf 100
router-id 5.5.5.5
log-adjacency-changes
redistribute rip metric 1000 metric-type 1subnets tag 5
passive-interface default
nopassive-interface Serial1/0
network 5.5.5.50.0.0.0 area 0
network 192.168.45.0 0.0.0.255area 0
distribute-list route-map 3 in
!
router rip
version 2
redistributeospf 100 metric 10
passive-interface default
nopassive-interface Serial1/1
network 192.168.25.0
noauto-summary

3、次优路径的控制
r3#sh ip route
Codes: L - local, C - connected, S -static, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA -OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
O E2    1.1.1.1 [110/20] via 192.168.34.4,00:11:48, Serial1/1
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected,Loopback0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/65] via 192.168.34.4,00:11:56, Serial1/1
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/129] via 192.168.34.4,00:11:56, Serial1/1
     11.0.0.0/32 is subnetted, 1 subnets
O E2    11.11.11.11 [110/20] via192.168.34.4, 00:11:48, Serial1/1
O E2 192.168.12.0/24 [110/20] via 192.168.34.4, 00:11:48, Serial1/1
     192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.23.0/24 is directly connected, Serial1/0
L       192.168.23.3/32 is directly connected, Serial1/0
O E2 192.168.25.0/24 [110/20] via 192.168.34.4, 00:11:57, Serial1/1
     192.168.34.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.34.0/24 is directly connected, Serial1/1
L       192.168.34.3/32 is directly connected, Serial1/1
O    192.168.45.0/24 [110/128] via 192.168.34.4, 00:11:57, Serial1/1
r3#traceroute 11.11.11.11

Type escape sequence to abort.
Tracing the route to 11.11.11.11

  1192.168.34.4 8 msec 8 msec 12 msec
  2192.168.45.5 16 msec 20 msec 16 msec
  3192.168.25.2 20 msec 16 msec 16 msec
  4192.168.12.1 20 msec *  20 msec
产生了次优路径!
QQ截图20160318085543.png
解决方法(1)通过修改管理距离AD:优选此方法!!!
distance ospf external 170
/ospf进程中修改外部路由的管理距离

r3#sh ip route
Codes: L - local, C - connected, S -static, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA -OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/2] via 192.168.23.2,00:00:17, Serial1/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected,Loopback0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/65] via 192.168.34.4,00:11:49, Serial1/1
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/129] via 192.168.34.4,00:11:49, Serial1/1
     11.0.0.0/32 is subnetted, 1 subnets
R       11.11.11.11 [120/2] via 192.168.23.2,00:00:17, Serial1/0
R    192.168.12.0/24 [120/1] via 192.168.23.2, 00:00:17, Serial1/0
     192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.23.0/24 is directly connected, Serial1/0
L       192.168.23.3/32 is directly connected, Serial1/0
R    192.168.25.0/24 [120/1] via 192.168.23.2, 00:00:18, Serial1/0
     192.168.34.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.34.0/24 is directly connected, Serial1/1
L       192.168.34.3/32 is directly connected, Serial1/1
O    192.168.45.0/24 [110/128] via 192.168.34.4, 00:11:50, Serial1/1
r3#traceroute 11.11.11.11
Type escape sequence to abort.
Tracing the route to 11.11.11.11

  1192.168.23.2 8 msec 8 msec 12 msec
  2192.168.12.1 8 msec *  8 msec
解决方法(2)通过分发列表distribute-list过滤:
r3#
router ospf 100
redistribute rip metric1000 metric-type 1 subnets tag 3
distribute-list route-map5 in
route-map 5 deny 10
match tag 5
route-map 5 permit 20
/过滤掉从r5重分发进来并打了标签tag5的路由信息
r3#sh ip route
Codes: L - local, C - connected, S -static, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA -OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/2] via 192.168.23.2,00:00:18, Serial1/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected,Loopback0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/65] via 192.168.34.4,00:01:32, Serial1/1
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/129] via 192.168.34.4,00:01:32, Serial1/1
     11.0.0.0/32 is subnetted, 1 subnets
R       11.11.11.11 [120/2] via 192.168.23.2,00:00:18, Serial1/0
R    192.168.12.0/24 [120/1] via 192.168.23.2, 00:00:18, Serial1/0
     192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.23.0/24 is directly connected, Serial1/0
L       192.168.23.3/32 is directly connected, Serial1/0
R    192.168.25.0/24 [120/1] via 192.168.23.2, 00:00:19, Serial1/0
     192.168.34.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.34.0/24 is directly connected, Serial1/1
L       192.168.34.3/32 is directly connected, Serial1/1
O    192.168.45.0/24 [110/128] via 192.168.34.4, 00:01:33, Serial1/1
r3#traceroute 11.11.11.11
Type escape sequence to abort.
Tracing the route to 11.11.11.11

  1192.168.23.2 8 msec 8 msec 8 msec
  2192.168.12.1 8 msec *  4 msec
----------------------------------------------------------------------------------------------
r5#
redistribute rip metric1000 metric-type 1 subnets tag 5
distribute-list route-map3 in
route-map 3 deny 10
match tag 3
route-map 3 permit 20
/过滤掉从r3重分发进来并打了标签tag3的路由信息!
r5#sh ip route
Codes: L - local, C - connected, S -static, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA -OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/2] via 192.168.25.2,00:00:11, Serial1/1
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/129] via 192.168.45.4,00:05:16, Serial1/0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/65] via 192.168.45.4,00:05:16, Serial1/0
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected,Loopback0
     11.0.0.0/32 is subnetted, 1 subnets
R       11.11.11.11 [120/2] via 192.168.25.2,00:00:11, Serial1/1
R    192.168.12.0/24 [120/1] via 192.168.25.2, 00:00:11, Serial1/1
R    192.168.23.0/24 [120/1] via 192.168.25.2, 00:00:11, Serial1/1
     192.168.25.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.25.0/24 is directly connected, Serial1/1
L       192.168.25.5/32 is directly connected, Serial1/1
O    192.168.34.0/24 [110/128] via 192.168.45.4, 00:05:16, Serial1/0
     192.168.45.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.45.0/24 is directly connected, Serial1/0
L       192.168.45.5/32 is directly connected, Serial1/0
r5#traceroute 11.11.11.11
Type escape sequence to abort.
Tracing the route to 11.11.11.11
  1192.168.25.2 12 msec 8 msec 8 msec
  2192.168.12.1 8 msec *  12 msec

r4#sh ip route
Codes: L - local, C - connected, S -static, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA -OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
O E1    1.1.1.1 [110/1064] via 192.168.45.5,00:08:10, Serial1/0
                 [110/1064] via 192.168.34.3,00:08:10, Serial1/1
      3.0.0.0/32 issubnetted, 1 subnets
O       3.3.3.3 [110/65] via 192.168.34.3,00:58:16, Serial1/1
     4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected,Loopback0
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/65] via 192.168.45.5,00:58:26, Serial1/0
     11.0.0.0/32 is subnetted, 1 subnets
O E1    11.11.11.11 [110/1064] via192.168.45.5, 00:08:10, Serial1/0
                     [110/1064] via192.168.34.3, 00:08:10, Serial1/1
O E1 192.168.12.0/24 [110/1064] via 192.168.45.5, 00:08:10, Serial1/0
                      [110/1064] via192.168.34.3, 00:08:10, Serial1/1
O E1 192.168.23.0/24 [110/1064] via 192.168.45.5, 00:08:11, Serial1/0
                      [110/1064] via192.168.34.3, 00:08:11, Serial1/1
O E1 192.168.25.0/24 [110/1064] via 192.168.45.5, 00:13:03, Serial1/0
                      [110/1064] via192.168.34.3, 00:10:53, Serial1/1
     192.168.34.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.34.0/24 is directly connected, Serial1/1
L       192.168.34.4/32 is directly connected, Serial1/1
     192.168.45.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.45.0/24 is directly connected, Serial1/0
L       192.168.45.4/32 is directly connected, Serial1/0
/实现了到RIP路由的负载均衡功能!

解决方法(3)通过策略路由route-map配合ACL实现过滤
r3(config)#router ospf 100
r3(config-router)#no distribute-listroute-map 5 in
r3(config-router)#redistributeospf 100 metric 1
r3(config-router)#end
r3#sh ip route
Codes: L - local, C - connected, S - static,R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA -OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
O E1    1.1.1.1 [110/1128] via 192.168.34.4,00:02:12, Serial1/1
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/65] via 192.168.34.4,00:02:12, Serial1/1
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/129] via 192.168.34.4,00:02:12, Serial1/1
     11.0.0.0/32 is subnetted, 1 subnets
O E1    11.11.11.11 [110/1128] via 192.168.34.4,00:02:12, Serial1/1
O E1 192.168.12.0/24 [110/1128] via 192.168.34.4, 00:02:12, Serial1/1
     192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.23.0/24 is directly connected, Serial1/0
L       192.168.23.3/32 is directly connected, Serial1/0
O E1 192.168.25.0/24 [110/1128] via 192.168.34.4, 00:02:13, Serial1/1
     192.168.34.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.34.0/24 is directly connected, Serial1/1
L       192.168.34.3/32 is directly connected, Serial1/1
O    192.168.45.0/24 [110/128] via 192.168.34.4, 00:02:13, Serial1/1
r3#traceroute 11.11.11.11

Type escape sequence to abort.
Tracing the route to 11.11.11.11

  1    192.168.34.4 8 msec 12 msec 8 msec
  2    192.168.45.5 16 msec 20 msec 16 msec
  3    192.168.25.2 20 msec 16 msec 16 msec
  4    192.168.23.3 28 msec 24 msec 28 msec
  5    192.168.34.4 28 msec 28 msec 24 msec
  6    192.168.45.5 36 msec 36 msec 32 msec
  7    192.168.25.2 36 msec 36 msec 36 msec
  8    192.168.23.3 44 msec 36 msec 48 msec
  9    192.168.34.4 40 msec 44 msec 40 msec
10    192.168.45.5 56 msec 52 msec 48 msec
11    192.168.25.2 52 msec 48 msec 56 msec
12    192.168.23.3 60 msec 56 msec 64 msec
13    192.168.34.4 56 msec 64 msec 60 msec
14    192.168.45.5 68 msec 72 msec 72 msec
15    192.168.25.2 72 msec 64 msec 72 msec
16    192.168.23.380 msec 76 msec 80 msec
17    192.168.34.4 76 msec 80 msec 80 msec
18    192.168.45.5 92 msec 84 msec 84 msec
19    192.168.25.2 92 msec 88 msec 84 msec
20    192.168.23.3 96 msec 100 msec 100 msec
21    192.168.34.4 92 msec 100 msec 100 msec
22    192.168.45.5 108 msec 108 msec 104 msec
23    192.168.25.2 108 msec 104 msec 104 msec
24    192.168.23.3 116 msec 112 msec 116 msec
25    192.168.34.4 108 msec 120 msec 112 msec
26    192.168.45.5 128 msec 120 msec 124 msec
27    192.168.25.2 124 msec 124 msec 124 msec
28    192.168.23.3 132 msec 124 msec 132 msec
29    192.168.34.4 132 msec 132 msec 136 msec
30    192.168.45.5 140 msec 140 msec 132 msec
产生环路!
r2#sh ip route
Codes: L - local, C - connected, S -static, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA -OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 192.168.23.3, 00:00:27,Serial1/0
                 [120/1] via 192.168.12.1,00:00:24, Ethernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
R       3.3.3.3 [120/1] via 192.168.23.3, 00:00:27,Serial1/0
     4.0.0.0/32 is subnetted, 1 subnets
R       4.4.4.4 [120/1] via 192.168.23.3, 00:00:27,Serial1/0
     5.0.0.0/32 is subnetted, 1 subnets
R       5.5.5.5 [120/1] via 192.168.25.5, 00:00:21,Serial1/1
                 [120/1] via 192.168.23.3,00:00:27, Serial1/0
     11.0.0.0/32 is subnetted, 1 subnets
R        11.11.11.11[120/1] via 192.168.23.3, 00:00:27, Serial1/0
                     [120/1] via 192.168.12.1,00:00:24, Ethernet0/0
     192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.12.0/24 is directly connected, Ethernet0/0
L       192.168.12.2/32 is directly connected, Ethernet0/0
     192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.23.0/24 is directly connected,Serial1/0
L       192.168.23.2/32 is directly connected, Serial1/0
     192.168.25.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.25.0/24 is directly connected, Serial1/1
L       192.168.25.2/32 is directly connected, Serial1/1
R    192.168.34.0/24 [120/1] via 192.168.23.3, 00:00:00, Serial1/0
R    192.168.45.0/24 [120/1] via 192.168.25.5, 00:00:21, Serial1/1
                      [120/1] via 192.168.23.3,00:00:00, Serial1/0
去往11.11.11.11优先从r3走,故产生环路!
QQ截图20160318085607.png
修改
r3(config-router)#redistribute ospf 100metric 10
r3#sh ip route
     1.0.0.0/32 is subnetted, 1 subnets
O E1    1.1.1.1 [110/1128] via 192.168.34.4,00:07:25, Serial1/1
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/65] via 192.168.34.4,00:07:25, Serial1/1
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/129] via 192.168.34.4,00:07:25, Serial1/1
     11.0.0.0/32 is subnetted, 1 subnets
O E1    11.11.11.11 [110/1128] via 192.168.34.4,00:07:25, Serial1/1
O E1 192.168.12.0/24 [110/1128] via 192.168.34.4, 00:07:25, Serial1/1
     192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.23.0/24 is directly connected, Serial1/0
L       192.168.23.3/32 is directly connected, Serial1/0
O E1 192.168.25.0/24 [110/1128] via 192.168.34.4, 00:07:25, Serial1/1
     192.168.34.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.34.0/24 is directly connected, Serial1/1
L       192.168.34.3/32 is directly connected, Serial1/1
O    192.168.45.0/24 [110/128] via 192.168.34.4, 00:07:25, Serial1/1
r3# traceroute 11.11.11.11
Tracing the route to 11.11.11.11
  1192.168.34.4 8 msec 12 msec 8 msec
  2 192.168.45.516 msec 20 msec 20 msec
  3192.168.25.2 16 msec 20 msec 16 msec
  4192.168.12.1 16 msec *  20 msec
产生次优路径!
QQ截图20160318085631.png
r2#sh ip route
     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 192.168.12.1, 00:00:11,Ethernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
R       3.3.3.3 [120/1] via 192.168.23.3, 00:00:10,Serial1/0
     4.0.0.0/32 is subnetted, 1 subnets
R       4.4.4.4 [120/10] via 192.168.25.5,00:00:12, Serial1/1
                 [120/10] via 192.168.23.3,00:00:10, Serial1/0
     5.0.0.0/32 is subnetted, 1 subnets
R       5.5.5.5 [120/1] via 192.168.25.5, 00:00:12,Serial1/1
     11.0.0.0/32 is subnetted, 1 subnets
R        11.11.11.11[120/1] via 192.168.12.1, 00:00:11, Ethernet0/0
     192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.12.0/24 is directly connected, Ethernet0/0
L       192.168.12.2/32 is directly connected, Ethernet0/0
     192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.23.0/24 is directly connected, Serial1/0
L       192.168.23.2/32 is directly connected, Serial1/0
     192.168.25.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.25.0/24 is directly connected, Serial1/1
L       192.168.25.2/32 is directly connected, Serial1/1
R     192.168.34.0/24 [120/1] via 192.168.23.3,00:00:11, Serial1/0
R    192.168.45.0/24 [120/1] via 192.168.25.5, 00:00:13, Serial1/1
基于上述几种次优路径办法解决!

运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-192304-1-1.html 上篇帖子: 配置Cisco 路由器的静态路由 下篇帖子: IPV6静态路由配置
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服E-mail:kefu@iyunv.com 客服QQ:1061981298


QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



合作伙伴: 青云cloud

快速回复 返回顶部 返回列表