设为首页 收藏本站
查看: 719|回复: 0

[经验分享] POJ 1860 Currency Exchange (bellman-ford判负环)

[复制链接]

尚未签到

发表于 2017-7-1 21:09:30 | 显示全部楼层 |阅读模式
Currency Exchange

题目链接:
  http://acm.hust.edu.cn/vjudge/contest/122685#problem/E

Description
  
  
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
  
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
  
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
  
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.
  


Input
  
  
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
  
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
  
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.
  


Output
  
  
If Nick can increase his wealth, output YES, in other case output NO to the output file.
  


Sample Input
  
  
3 2 1 20.0
  
1 2 1.00 1.00 1.00 1.00
  
2 3 1.10 1.00 1.10 1.00
  


Sample Output
  
  
YES
  


Hint
  
  


题意:
  
  
给出两种货币之间的汇率及税价.
  
求能否经过一定的兑换过程使得价值增加.
  


题解:
  
  
抽象成图模型,兑换途径即为路径.
  
问题转换为判断图中是否存在一个正环.
  
直接用bellman-ford判负环的方法即可.
  
注意初始状态:dis[start] = 初始时的钱.
  


代码:
#include <iostream>  
#include <cstdio>
  
#include <cstring>
  
#include <cmath>
  
#include <algorithm>
  
#include <vector>
  
#include <queue>
  
#include <map>
  
#include <set>
  
#define LL long long
  
#define eps 1e-8
  
#define maxn 310
  
#define inf 0x3f3f3f3f
  
#define IN freopen(&quot;in.txt&quot;,&quot;r&quot;,stdin);
  
using namespace std;
  

  
int sign(double x){
  if(fabs(x)<eps) return 0;
  return x<0? -1:1;
  
}
  

  
int m,n,s;
  
double cur;
  
int edges, u[maxn], v[maxn];
  
double rate[maxn], cost[maxn];
  
int first[maxn], next[maxn];
  
//初始化edge和first
  
double dis[maxn];
  

  
void add_edge(int s, int t, double a, double b) {
  u[edges] = s; v[edges] = t;
  rate[edges] = a; cost[edges] = b;
  next[edges] = first;
  first = edges++;
  
}
  

  
bool bellman(int s) {
  for(int i=1; i<=n; i++) dis = -1;
  dis = cur;  //!!!
  

  for(int i=1; i<=n; i++) {
  for(int e=0; e<edges; e++) {
  double tmp = (dis[u[e]]-cost[e])*rate[e];
  if(sign(dis[v[e]]-tmp) < 0) {
  dis[v[e]] = tmp;
  if(i == n) return 0;
  }
  }
  }
  

  return 1;
  
}
  

  
int main(int argc, char const *argv[])
  
{
  //IN;
  

  while(scanf(&quot;%d %d %d %lf&quot;, &n,&m,&s,&cur) != EOF)
  {

  memset(first, -1,>  edges = 0;
  

  for(int i=1; i<=m; i++) {
  int u,v; double ra,rb,ca,cb;
  scanf(&quot;%d %d %lf %lf %lf %lf&quot;, &u,&v,&ra,&ca,&rb,&cb);
  add_edge(u,v,ra,ca);
  add_edge(v,u,rb,cb);
  }
  

  if(!bellman(s)) puts(&quot;YES&quot;);
  else puts(&quot;NO&quot;);
  }
  

  return 0;
  
}

运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-390216-1-1.html 上篇帖子: 安装Exchange 2010 时报错"UserMailbox 必须强制使用 Database" 下篇帖子: RabbitMQ~说说Exchange的几种模式
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服E-mail:kefu@iyunv.com 客服QQ:1061981298


QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



合作伙伴: 青云cloud

快速回复 返回顶部 返回列表