设为首页 收藏本站
查看: 836|回复: 0

[经验分享] hdu4941 Magical Forest

[复制链接]

尚未签到

发表于 2017-7-4 20:28:53 | 显示全部楼层 |阅读模式
Problem Description


There is a forest can be seen as N * M grid. In this forest, there is some magical fruits, These fruits can provide a lot of energy, Each fruit has its location(Xi, Yi) and the energy can be provided Ci.



However, the forest will make the following change sometimes:

1. Two rows of forest exchange.

2. Two columns of forest exchange.

Fortunately, two rows(columns) can exchange only if both of them contain fruits or none of them contain fruits.



Your superior attach importance to these magical fruit, he needs to know this forest information at any time, and you as his best programmer, you need to write a program in order to ask his answers quick every time.




Input


The input consists of multiple test cases.



The first line has one integer W. Indicates the case number.(1<=W<=5)



For each case, the first line has three integers N, M, K. Indicates that the forest can be seen as maps N rows, M columns, there are K fruits on the map.(1<=N, M<=2*10^9, 0<=K<=10^5)



The next K lines, each line has three integers X, Y, C, indicates that there is a fruit with C energy in X row, Y column. (0<=X<=N-1, 0<=Y<=M-1, 1<=C<=1000)



The next line has one integer T. (0<=T<=10^5)

The next T lines, each line has three integers Q, A, B.

If Q = 1 indicates that this is a map of the row switching operation, the A row and B row exchange.

If Q = 2 indicates that this is a map of the column switching operation, the A column and B column exchange.

If Q = 3 means that it is time to ask your boss for the map, asked about the situation in (A, B).

(Ensure that all given A, B are legal. )






Output


For each case, you should output &quot;Case #C:&quot; first, where C indicates the case number and counts from 1.



In each case, for every time the boss asked, output an integer X, if asked point have fruit, then the output is the energy of the fruit, otherwise the output is 0.






Sample Input



1
3 3 2
1 1 1
2 2 2
5
3 1 1
1 1 2
2 1 2
3 1 1
3 2 2






Sample Output



Case #1:
1
2
1


HintNo two fruits at the same location.








题目中的N, M 太大   所以不能直接记录

用两个map表示,row = j 表示 i行换到了j行,反之同理  col表示列

另外一个map   maze记录<i, j>这个位置的&#20540;

每次查询前先将正确的行列在row,col中映射。输出答案就可以




#include <cstdio>
#include <ctime>
#include <cstdlib>
#include <cstring>
#include <queue>
#include <string>
#include <set>
#include <stack>
#include <map>
#include <cmath>
#include <vector>
#include <iostream>
#include <algorithm>
#include <bitset>
#include <fstream>
using namespace std;
//LOOP
#define FF(i, a, b) for(int i = (a); i < (b); ++i)
#define FE(i, a, b) for(int i = (a); i <= (b); ++i)
#define FED(i, b, a) for(int i = (b); i>= (a); --i)
#define REP(i, N) for(int i = 0; i < (N); ++i)
#define CLR(A,value) memset(A,value,sizeof(A))
//OTHER
#define PB push_back
//INPUT
#define RI(n) scanf(&quot;%d&quot;, &n)
#define RII(n, m) scanf(&quot;%d%d&quot;, &n, &m)
#define RIII(n, m, k) scanf(&quot;%d%d%d&quot;, &n, &m, &k)
#define RIV(n, m, k, p) scanf(&quot;%d%d%d%d&quot;, &n, &m, &k, &p)
#define RV(n, m, k, p, q) scanf(&quot;%d%d%d%d%d&quot;, &n, &m, &k, &p, &q)
#define RS(s) scanf(&quot;%s&quot;, s)
//OUTPUT
#define sqr(x) (x) * (x)
typedef long long LL;
typedef unsigned long long ULL;
typedef vector <int> VI;
const double eps = 1e-9;
const int MOD = 1000000007;
const double PI = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int maxn = 100010;
map<int, int>col, row;
map<pair<int, int>, int>maze;
int main()
{
//freopen(&quot;0.txt&quot;, &quot;r&quot;, stdin);
int T, n, m, k, a, t;
RI(T);
FE(kase, 1, T)
{
row.clear(), col.clear(), maze.clear();
printf(&quot;Case #%d:\n&quot;, kase);
RIII(n, m, k);
int x, y, c, Q;
REP(i, k)
{
RIII(x, y, c);
maze[make_pair(x, y)] = c;
}
int tx, ty;
RI(Q);
while (Q--)
{
RIII(c, x, y);
tx = x, ty = y;
if (c == 2)
{
if (col.count(x))   tx = col[x];
if (col.count(y))   ty = col[y];
col[x] = ty;
col[y] = tx;
}
else if (c == 1)
{
if (row.count(x))   tx = row[x];
if (row.count(y))   ty = row[y];
row[x] = ty;
row[y] = tx;
}
else
{
if (row.count(x))
x = row[x];
if (col.count(y))
y = col[y];
a = 0;
if (maze.count(make_pair(x, y)))
a = maze[make_pair(x, y)];
printf(&quot;%d\n&quot;, a);
}
}
}
return 0;
}

运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-390777-1-1.html 上篇帖子: Spring RabbitMQ 延迟队列 下篇帖子: 杂项之rabbitmq
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服E-mail:kefu@iyunv.com 客服QQ:1061981298


QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



合作伙伴: 青云cloud

快速回复 返回顶部 返回列表