设为首页 收藏本站
查看: 1078|回复: 0

BGP (IBGP EBP)实验

[复制链接]
累计签到:512 天
连续签到:1 天
发表于 2017-12-11 14:56:45 | 显示全部楼层 |阅读模式

11111

11111

R1:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!         
interface Ethernet0/0
ip address 12.1.1.1 255.255.255.0
half-duplex
!         
interface Ethernet0/1
ip address 13.1.1.1 255.255.255.0
half-duplex
!         
interface Ethernet0/2
no ip address
shutdown
half-duplex
!         
interface Ethernet0/3
no ip address
shutdown
half-duplex
!         
router ospf 110
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 12.1.1.0 0.0.0.255 area 0
network 13.1.1.0 0.0.0.255 area 0
!         
router bgp 1
no synchronization
bgp router-id 1.1.1.1
bgp log-neighbor-changes
neighbor wolf peer-group         //定义peer-group
neighbor wolf remote-as 1
neighbor wolf update-source Loopback0
neighbor 2.2.2.2 peer-group wolf
neighbor 3.3.3.3 peer-group wolf
no auto-summary
!         
no ip http server
no ip http secure-server
!         
!         
!         
!         
==========================================
R2:
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!         
interface Ethernet0/0
ip address 12.1.1.2 255.255.255.0
half-duplex
!         
interface Ethernet0/1
no ip address
shutdown
half-duplex
!         
interface Ethernet0/2
no ip address
shutdown
half-duplex
!         
interface Ethernet0/3
no ip address
shutdown
half-duplex
!         
interface Serial1/0
ip address 24.1.1.2 255.255.255.0
serial restart-delay 0
clock rate 64000
!         
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!         
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!         
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!         
router ospf 110
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 12.1.1.0 0.0.0.255 area 0
!         
router bgp 1
no synchronization
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self    //针对R1下一跳指向我
neighbor 3.3.3.3 remote-as 1
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self          //对于BGP边界路由器需要将邻居路由器的下一跳指向自己
neighbor 24.1.1.4 remote-as 4
no auto-summary
!         
no ip http server
no ip http secure-server
!         
!   
内部BGP路由表:
R2#sh ip bgp
BGP table version is 3, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 4.4.4.0/24       24.1.1.4                 0             0 4 i
*>i5.5.5.0/24       3.3.3.3                  0    100      0 5 i
R2#
==========================================
R3:
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!         
interface Ethernet0/0
no ip address
shutdown
half-duplex
!         
interface Ethernet0/1
ip address 13.1.1.3 255.255.255.0
half-duplex
!         
interface Ethernet0/2
no ip address
shutdown
half-duplex
!         
interface Ethernet0/3
no ip address
shutdown
half-duplex
!         
interface Serial1/0
ip address 35.1.1.3 255.255.255.0
serial restart-delay 0
clock rate 64000
!         
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!         
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!         
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!         
router ospf 110
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.0 0.0.0.255 area 0
network 13.1.1.0 0.0.0.255 area 0
!         
router bgp 1
no synchronization
bgp router-id 3.3.3.3
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
neighbor 5.5.5.5 remote-as 5
neighbor 5.5.5.5 ebgp-multihop 255
neighbor 5.5.5.5 update-source Loopback0
no auto-summary
!         
no ip http server
no ip http secure-server
ip route 5.5.5.5 255.255.255.255 Serial1/0
!         
!         
==========================================
R4:
interface Loopback0
ip address 4.4.4.4 255.255.255.0
!         
interface Serial0/0
ip address 24.1.1.4 255.255.255.0
serial restart-delay 0
!         
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!         
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!         
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!         
router bgp 4
no synchronization
bgp router-id 4.4.4.4
bgp log-neighbor-changes
network 4.4.4.0 mask 255.255.255.0
neighbor 24.1.1.2 remote-as 1
no auto-summary
!         
no ip http server
no ip http secure-server
!         
!         
!  

外部BGP路由表:
R4#sh ip bgp
BGP table version is 3, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 4.4.4.0/24       0.0.0.0                  0         32768 i
*> 5.5.5.0/24       24.1.1.2                               0 1 5 i
R4#      
==========================================
R5:
interface Loopback0
ip address 5.5.5.5 255.255.255.0
!         
interface Serial0/0
ip address 35.1.1.5 255.255.255.0
serial restart-delay 0
!         
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!         
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!         
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!         
router bgp 5
no synchronization
bgp log-neighbor-changes
network 5.5.5.0 mask 255.255.255.0
neighbor 3.3.3.3 remote-as 1
neighbor 3.3.3.3 ebgp-multihop 255
neighbor 3.3.3.3 update-source Loopback0
no auto-summary
!         
no ip http server
no ip http secure-server
ip route 3.3.3.3 255.255.255.255 Serial0/0


运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-423000-1-1.html 上篇帖子: Hub&Spoke NBMA跑OSPF实验报告 下篇帖子: 【求】Cisco 无线完整的视频
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服E-mail:kefu@iyunv.com 客服QQ:1061981298


QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



合作伙伴: 青云cloud

快速回复 返回顶部 返回列表