设为首页 收藏本站
查看: 353|回复: 0

[经验分享] Cisco Switches/Router Layer 3 Security

[复制链接]

尚未签到

发表于 2018-7-15 06:49:58 | 显示全部楼层 |阅读模式
  1. Enable secure Telnet access to a router user interface, and consider using Secure Shell (SSH) instead of Telnet.
  2. Enable SNMP security, particularly adding SNMPv3 support.
  3. Turn off all unnecessary services on the router platform ( AutoSecure ).
  4. Turn on logging to provide an audit trail.
  5. Enable routing protocol authentication.
  6. Enable the CEF forwarding path to avoid using flow-based paths like fast switching.
  7. Using RPF Checks
  example:
  R1(config)# ip cef
  R1(config)# int s0/0
  R1(config-if)# ip verify unicast source reachable-via rx allow-default
  8. Using ACL to prevent TCP SYN Flood from outside
  example:
  ip access-list extended prevent-syn
  permit tcp any 10.0.0.0 0.255.255.255 established
  deny tcp any 1.0.0.0 0.255.255.255
  permit (whatever)
  !

  interface s0/0  # Internet>  ip access-group prevent-syn in

  Notes: The above ACL works well when clients outside a network are not allowed to make TCP connections into the network. However, in cases where some inbound TCP connections are allowed, this ACL cannot be used. Another Cisco IOS feature, called TCP intercept, provides an>  example:
  ip access-list extended match-tcp-from-internet
  permit tcp any 10.0.0.0 0.255.255.255
  ip tcp intercept-list match-tcp-from-internet
  ip tcp intercept mode watch
  ip tcp intercept watch-timeout 20
  9.Cisco IOS Firewall CBAC
  example:
  ip inspect name>

  ip inspect name>
  ip inspect name>  !
  ip access-list extended IOS_FW
  deny ip any any
  !

  interface Serial0/0  #Internet>  ip address 192.168.1.3 255.255.255.0
  ip access-group IOS_FW in

  ip inspect>  !
  10. Cisco IOS Zone-Based Firewall
  example:
DSC0000.jpg

  In this example, the network administrators have decided to apply the following policies to traffic from the LAN zone going through the WAN zone:
  ■ Only traffic from the LAN subnet is allowed.
  ■ HTTP traffic to corporate web-based intranet servers is allowed.
  ■ All other HTTP traffic is allowed but policed to 1 Mbps.
  ■ ICMP is blocked.
  ■ For all other traffic, the TCP and UDP timeouts must be lowered to 300 seconds.
  Follow these steps to configure ZFW:
  Step 1: Decide the zones you will need, and create them on the router.
  Branch1(config)# zone security LAN
  Branch1(config-sec-zone)# description LAN zone
  !
  Branch1(config)# zone security WAN
  Branch1(config-sec-zone)# description WAN zone
  Step 2: Decide how traffic should travel between the zones, and create zone-pairs on the router.
  Branch1(config)# zone-pair security Internal source LAN destination WAN
  Branch1(config)# zone-pair security External source WAN destination LAN

  Step 3: Create>  Branch1(config)# ip access-list extended LAN-Subnet
  Branch1(config-ext-nacl)# permit ip 10.1.1.0 0.0.0.255 any
  !
  Branch1(config-ext-nacl)# ip access-list extended Web_Servers
  Branch1(config-ext-nacl)# permit tcp 10.1.1.0 0.0.0.255 host 10.150.2.1
  Branch1(config-ext-nacl)# permit tcp 10.1.1.0 0.0.0.255 host 10.150.2.2
  !
  Branch1(config-ext-nacl)# class-map type inspect match-all Corp_Servers
  Branch1(config-cmap)# match access-group name Web_Servers
  Branch1(config-cmap)# match protocol http
  !
  Branch1(config-cmap)# class-map type inspect Other_HTTP
  Branch1(config-cmap)# match protocol http
  Branch1(config-cmap)# match access-group name LAN_Subnet
  !
  Branch1(config-cmap)# class-map type inspect ICMP
  Branch1(config-cmap)# match protocol icmp
  !
  Branch1(config-cmap)# class-map type inspect Other_Traffic
  Branch1(config-cmap)# match access-group name LAN_Subnet
  Branch1(config)# parameter-map type inspect Timeouts
  Branch1(config-profile)# tcp>
  Branch1(config-profile)# udp>

  Step 4: Assign policies to the traffic by creating policy maps and associating>  Branch1(config-profile)# policy-map type inspect LAN2WAN
  Branch1(config-pmap)# class type inspect Corp_Servers
  Branch1(config-pmap-c)# inspect
  !
  Branch1(config-pmap-c)# class type inspect Other_HTTP
  Branch1(config-pmap-c)# inspect
  Branch1(config-pmap-c)# police rate 1000000 burst 8000
  !
  Branch1(config-pmap-c)# class type inspect ICMP
  Branch1(config-pmap-c)# drop
  !
  Branch1(config-pmap-c)# class type inspect Other_Traffic
  Branch1(config-pmap-c)# inspect Timeouts
  Step 5: Assign the policy maps to the appropriate zone-pair.
  Branch1(config)# zone-pair security Internal source LAN destination WAN
  Branch1(config-sec-zone-pair)# service-policy type inspect LAN2WAN
  Step 6: Assign interfaces to zones. An interface may be assigned to only one security zone.
  Branch1(config)# interface fa 0/0
  Branch1(config-if)# zone-member security LAN
  !
  Branch1(config-if)# interface s0/0/0
  Branch1(config-if)# zone-member security WAN

运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-537216-1-1.html 上篇帖子: Cisco 的 NAT 路由表命令 下篇帖子: Cisco ASA 配置 SSH 接入
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服E-mail:kefu@iyunv.com 客服QQ:1061981298


QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



合作伙伴: 青云cloud

快速回复 返回顶部 返回列表