设为首页 收藏本站
查看: 908|回复: 0

[经验分享] zabbix 实战邮箱告警之msmtp

[复制链接]
累计签到:1 天
连续签到:1 天
发表于 2014-12-29 08:41:22 | 显示全部楼层 |阅读模式
Last modified: Nov. 17, 2012

Contents
1 - Summary
2 - Dependencies
3 - Install msmtp
4 - Msmtp configuration
5 - Shell script
6 - Zabbix configuration

1 - Summary

This guide will show you how to use msmtp with TLS/SSL capabilities for email
notifications in Zabbix Server in FreeBSD. Msmtp is an SMTP client used to send
email. Zabbix Server is the server software that installs on a server and
receives information from network devices. Zabbix is an open source monitoring
solution. This has been tested in FreeBSD 9.0 i386/amd64.

2 - Dependencies

Install following packages.
# cd ~
# sudo pkg_add -r ca_root_nss
Password:
# sudo pkg_add -r p5-LWPx-ParanoidAgent
Password:
# sudo pkg_add -r wget
Password:
# rehash
# wget --no-check-certificate https://github.com/bagder/curl/raw/master/lib/mk-ca-bundle.pl
# perl mk-ca-bundle.pl
# sudo chown root:wheel ca-bundle.crt
Password:
# sudo chmod 555 ca-bundle.crt
Password:
# sudo mv ca-bundle.crt /usr/local/etc/
Password:
# rm -f certdata.txt mk-ca-bundle.pl
# sudo pkg_add -r libidn
Password:
# sudo pkg_add -r portupgrade
Password:
# sudo portsnap fetch extract
Password:
There is an entry in /usr/ports/UPDATING regarding pkg-config.
# vi /usr/ports/UPDATING
# sudo portupgrade -fo devel/pkgconf pkg-config-\*
Password:

3 - Install msmtp

Install the msmtp port.
# cd /usr/ports/mail/msmtp/
Select only the following options.
  
  • OPENSSL        Adds support for SSL (Secure Socket Layer)
      
  • IDN            Enable Internationalized Domain Names
    # sudo make config
    Password:
    # sudo make
    Password:
    # sudo make install
    Password:
    # sudo make clean
    Password:

    4 - Msmtp configuration

    Create your own configuration file. Here is an example that uses a Gmail
    account which utilizes TLS.
      account default
      host smtp.googlemail.com
      port 587
      from testuser@gmail.com
      tls on
      tls_starttls on
      tls_trust_file /usr/local/etc/ca-bundle.crt
      auth on
      user testuser@gmail.com
      password **********
      syslog LOG_MAIL
    # pkg_info -L zabbix2-server-* | grep rc.d
    /usr/local/etc/rc.d/zabbix_server
    # grep required_files /usr/local/etc/rc.d/zabbix_server
    required_files="/usr/local/etc/zabbix2/${name}.conf"
    # sudo vi /usr/local/etc/zabbix2/msmtprc
    Password:
    # id zabbix
    uid=122(zabbix) gid=122(zabbix) groups=122(zabbix)
    # sudo chown zabbix:zabbix /usr/local/etc/zabbix2/msmtprc
    Password:
    # sudo chmod 600 /usr/local/etc/zabbix2/msmtprc
    Password:

    5 - Shell script

    Modify the Zabbix server configuration to have include the alert script path.
      AlertScriptsPath=/usr/local/etc/zabbix2/zabbix/alertscripts
    # sudo vi /usr/local/etc/zabbix2/zabbix_server.conf
    Password:
    # sudo /usr/local/etc/rc.d/zabbix_server restart
    Password:
    # sudo /usr/local/etc/rc.d/zabbix_server status
    Password:
    zabbix_server is running as pid 28283 28284 28285 28286 28287 28288 28289 28290
    28291 28292 28293 28294 28295 28296 28297 28298 28299 28300 28301 28302 28303
    28304 28305 28306 28307 28308 28309.

    Here is shell script that can be used in Zabbix to send email notifications.
      #!/bin/sh
      printf=/usr/bin/printf
      from="testuser@gmail.com"
      recipient="$1"
      subject="$2"
      body="$3"
      msmtp=/usr/local/bin/msmtp
      msmtp_config=/usr/local/etc/zabbix2/msmtprc
      $printf "From: $from\nTo: $recipient\nSubject: $subject\n\n$body" | $msmtp \
        --file=$msmtp_config -t
      exit 0
    # sudo vi /usr/local/etc/zabbix2/zabbix/alertscripts/zabbix_notifications.sh
    Password:
    # sudo chown root:wheel /usr/local/etc/zabbix2/zabbix/alertscripts/zabbix_notifications.sh
    Password:
    # sudo chmod 555 /usr/local/etc/zabbix2/zabbix/alertscripts/zabbix_notifications.sh
    Password:

    6 - Zabbix configuration

    Log into the Zabbix website as a user with Administrator privileges. Hover over
    Administration and click on Media types. Click on Create media type on the
    right-hand side of the screen. Type in the following and click on Save.

    Hover over Administration and click on Users. Select Users from the drop-down
    menu on the right-hand side of the screen. Select the user. Click on the Media
    tab and click on Add. Type in the following.

    Hover over Configuration and click on Actions. Select one of the Actions listed
    and go to the Operations tab and click on Edit. In the drop-down box next to
    Send only to, select Script. Make sure to save the Action.

  • 运维网声明 1、欢迎大家加入本站运维交流群:群②:261659950 群⑤:202807635 群⑦870801961 群⑧679858003
    2、本站所有主题由该帖子作者发表,该帖子作者与运维网享有帖子相关版权
    3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
    4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
    5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
    6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
    7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
    8、联系人Email:admin@iyunv.com 网址:www.yunweiku.com

    所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其承担任何法律责任,如涉及侵犯版权等问题,请您及时通知我们,我们将立即处理,联系人Email:kefu@iyunv.com,QQ:1061981298 本贴地址:https://www.yunweiku.com/thread-39448-1-1.html 上篇帖子: zabbix2.4.2实战监控mysql5.6性能 下篇帖子: 使用zabbix全方位监控MySQL 邮箱
    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    扫码加入运维网微信交流群X

    扫码加入运维网微信交流群

    扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

    扫描微信二维码查看详情

    客服E-mail:kefu@iyunv.com 客服QQ:1061981298


    QQ群⑦:运维网交流群⑦ QQ群⑧:运维网交流群⑧ k8s群:运维网kubernetes交流群


    提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


    本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!



    合作伙伴: 青云cloud

    快速回复 返回顶部 返回列表