|
实验目的:
了解并掌握EIGRP的配置方法及特性。用EIGRP动态路由协议实现全网的互通。
实验拓扑:
基础配置:
R1
hostname R1
!
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
no shutdown
!
interface FastEthernet0/1
ip address 1.1.1.254 255.255.255.0
no shutdown
R2
hostname R2
!
interface FastEthernet0/0
ip address 12.1.1.2 255.255.255.0
no shutdown
!
interface FastEthernet0/1
ip address 23.1.1.2 255.255.255.0
no shutdown
!
interface FastEthernet1/0
ip address 2.2.2.254 255.255.255.0
no shutdown
R3
hostname R3
!
interface FastEthernet0/0
ip address 23.1.1.3 255.255.255.0
no shutdown
!
interface FastEthernet0/1
ip address 3.3.3.254 255.255.255.0
no shutdown
实验步骤:
R1
router eigrp 90 #EIGRP 的AS号为90,在同一路由域内,此 AS 号必需相同
network 12.0.0.0 #以主类宣告的方法通告对应的网络号
network 1.0.0.0
no auto-summary #关闭自动汇总
R2
router eigrp 90
network 12.0.0.0
network 23.0.0.0
network 2.0.0.0
no auto-summary
R3
router eigrp 90
network 23.0.0.0
network 3.0.0.0
no auto-summary
结果验证:
R2
show ip eigrp neighbors #在R2上查看与R1和R3的邻居表
IP-EIGRP neighbors for process 90
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 12.1.1.1 Fa0/0 11 00:17:11 40 1000 0 7
1 23.1.1.3 Fa0/1 12 00:17:11 40 1000 0 7
H:队列 0-先建立邻居的路由条目。
Hold=3*hello时间(hello大于等于T1链路上每5秒发送一次,小于等于T1 链路上60S发送一次。)=15s&180s:用来判断15s&180s内两路由器有没有收到hello包邻居就会down。
Uptime:和邻居建立的时间。
SRTT(smooth Round-Trip timer):平滑的往返时间(ms)。本地给邻居发送一个可靠报文,收到回应的ACK报文的时间。(越小越好)。
RTO(retransmission timeout):重传超时时间(ms)。本地给邻居发送一个可靠报文,没有收到ACK面进行重传该报文的等待时间。6*SRTT=RTO。16次后重置邻居。
R2
show ip eigrp topology #在R2上查看拓扑表
IP-EIGRP Topology Table for AS 90/ID(23.1.1.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status
P 1.1.1.0/24, 1 successors, FD is 30720
via 12.1.1.1 (30720/28160), FastEthernet0/0
P 2.2.2.0/24, 1 successors, FD is 28160
via Connected, FastEthernet1/0
P 3.3.3.0/24, 1 successors, FD is 30720
via 23.1.1.3 (30720/28160), FastEthernet0/1
P 12.1.1.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 23.1.1.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/1
R2
show ip route #在R2上查看路由表
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/30720] via 12.1.1.1, 00:38:16, FastEthernet0/0
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, FastEthernet1/0
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 [90/30720] via 23.1.1.3, 00:38:16, FastEthernet0/1
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, FastEthernet0/0
23.0.0.0/24 is subnetted, 1 subnets
C 23.1.1.0 is directly connected, FastEthernet0/1
|
|